Take the 2-minute tour ×
ExpressionEngine® Answers is a question and answer site for administrators, end users, developers and designers for ExpressionEngine® CMS. It's 100% free, no registration required.

In my template, I have this code:

<dd>{categories backspace="2"}{category_name}, {/categories}{if habitat_category_other} ({habitat_category_other}){/if}</dd>

When rendered in the template, it is converted into:

<dd><p>Monarch Waystation, National Wildlife Federation, Other</p> (Monarchs Across Georgia)</dd>

which gives an odd line break.

How do I get rid of these automatically added paragraph tags? I don't see anything about this in the documentation for the categories tag pair.

Thanks!

CORRECTION:

The problem is actually occurring with a different line of code (not the categories tag -- although I will have to check that one now, too, because it's probably also malfunctioning). The offending line is:

<dd>{habitat_programs}{if habitat_program_other} ({habitat_program_other}){/if}</dd>

where "habitat_programs" is a "Checkboxes" fieldtype. How does this change the answer if it's not the "Categories" tag pair?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Edit your field and ensure that Default Text Formatting is set to None, this should fix the issue.

share|improve this answer
    
thanks! I just realized that, too. Duh. I should really sit on these questions a little longer before posting them. :) –  Amy Witty Feb 13 at 16:01
    
Amy, I don't know how many times I've posted a question somewhere to only figure out the answer minutes later. It happens to everyone. –  CreateSean Feb 13 at 18:44

Did you change your field type to a checkbox from something else?

Check the Default Text Formatting option in your field options. If it's set to something other than "none" change it to none. If it's on none, change it to something else, then back to none. In either case, a checkbox should show up to update entries with your new choice-- check it. And then click Update.

Everything should be reset to none now, and the tags should be gone.

share|improve this answer

You could try adding style="linear" to your {categories} tag.

Per this docs entry.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.