ExpressionEngine® Answers is a question and answer site for administrators, end users, developers and designers for ExpressionEngine® CMS. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to expression engine. I have installed expression engine using my own created theme.

But when I am trying to install, it is giving error as "Your config file does not appear to be formatted correctly."

What I did :-

I have installed fresh copy of expression engine at local and then created theme after that on server, I have again installed expression engine but copied the theme to site_themes folder ad then installed using the server host, db and username. But it is giving the error stated above.

Any help is really appreciated.

share|improve this question
So EE was working and now it isnt or its never been working? – stuartmcd69 May 5 '14 at 7:43
at my local when i created theme, its working. But on the server, when i installed ee with my theme, its not working. – user930026 May 5 '14 at 7:52
up vote 3 down vote accepted

I had a look at the link you posted. The error appears to be a different one. "No database connection settings were found in the database config file."

Did you follow the official instructions: ?

Usually you get the error you've mentioned if ExpressionEngine has not been installed yet. This appears to be the case. Please visit and complete the installation.

share|improve this answer
The problem is that when i follow the instructions , I have to stop at this as if i click it installs new rather then installing my theme and the error "No database connection settings were found in the database config file." was as i tried coping the local config file to server but otherwise the error is as given in question. – user930026 May 5 '14 at 8:26
Alright, I suggest the following: 1) Upload your complete 'local' install to the server. 2) Upload the Database if you haven't already done that. I'd recommend to use phpmyadmin. 3) Verify all permissions according to the official install instructions 4) Open up config.php and database.php and verify / update all settings... Here's some additional info – Franz May 5 '14 at 9:17
One more thing: Since you're not 'updating' ExpressionEngine to a newer version, it won't be necessary to run the install again. Simply make sure to update that both database.php and config.php reflect the new environment. – Franz May 5 '14 at 9:19

Firstly, when you say "theme" I am assuming you mean a set of templates.

There are a few ways to approach this.

Copy your entire local installation to the remote server

If you have the site working on your local machine and simply want to now put it on a remote server then you do not need to run the installer on the server. You can copy the files to your server via FTP then create a backup of your local database and use this to recreate a database that your remote site can connect to.

The problem then, however, is that you will need to update any paths used to make them work on the remote server. This can be done manually but is a bit fiddly or you can look at something like Deeploy Helper or Reelocate which will let you update all the paths used in one place.

My preferred option is to use Focus Labs Config which will allow you to create different configs to be used in different environments.

or, Install a fresh copy of EE and update parts of it

This is the approach you are partly taking already. Basically create a completely clean installation of EE on your remote server, complete with a fresh database, then replace some of the files and upload a copy of your database.

Once you have a fresh installation on the remote server:

  1. Back up your local database to an SQL file and use that file to overwrite the freshly installed remote database.

  2. Then copy your templates directory to overwrite the one on the server

  3. If you have any third party add-ons installed then you should also copy the /system/expressionengine/third-party and /themes directories to your remote server.

  4. Copy your local images directory to the remote server as well as any upload directories you have created.

  5. Update the config file on the remote server to reflect the new environment

  6. You will also need to update paths and set permissions for config files, templates, cache, and file upload directories to reflect the new environment

share|improve this answer

Have you set permissions to 666 on config and database php files?

share|improve this answer
yes permissions have been set – user930026 May 5 '14 at 8:28
You've got config file issues then. See if this --> is similar to your problem – ObiWanKobi May 5 '14 at 9:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.