Take the 2-minute tour ×
ExpressionEngine® Answers is a question and answer site for administrators, end users, developers and designers for ExpressionEngine® CMS. It's 100% free, no registration required.

I'm having the same issue described here. I've tried the working solution but it hasn't worked for. In config.local.php I have $env_config['cookie_domain'] = 'buckley.dev'; and I am still unable to login. This site is using the focuslab multi environment config set up in case that is relevant.

This was working last night when I installed EE 2.8.1 but when I tried to login this morning it won't let me. I am also unable to log in to the staging site.

I have also tried logging in with Firefox unsuccessfully.

In config.master.php I have the following

//$env_config['cookie_domain'] = "";
$env_config['cookie_path'] = "";
$env_config['cookie_prefix'] = "bulkley";
$env_config['admin_session_type'] = "c";
$env_config['user_session_type'] = "c";
$env_config['require_ip_for_login'] = "n";
$env_config['require_ip_for_posting'] = "n"; 
$env_config['secure_forms'] = "n";

Also I am able to login via a front end form so I know my user/password are correct. I am however unable to access the CP.

Interestingly if I login via the CP (and get redirected) and then I view the front end of the site when previously logged out, I am now logged in. So the issue isn't that I'm not logging in but that I can't access the control panel when logged in.

share|improve this question
    
have you tried: $env_config['user_session_type'] = 's'; $env_config['admin_session_type'] = 's'; ? –  erwinheiser May 7 at 14:35
    
Erwin, yes. Have found the solution see my answer below. –  CreateSean May 7 at 14:44

1 Answer 1

Some more googling and I found the answer here. The issue is with Structure and setting it to redirect to structure on login.

I finally found out that Structure 3.3.1 is the culprit when you set it to redirect to Structure on login. You can get past it by editing the config file and change $config['allow_extensions'] = 'y'; to $config['allow_extensions'] = 'n';

Have done this and turned off the redirect within structure and all is good now.

share|improve this answer
    
I gather currently no other issues with Structure 3.3.1 and EE2.8.1? Starting a new build next week. –  erwinheiser May 12 at 20:55
    
Erwin, that is correctly –  CreateSean May 13 at 0:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.