Take the 2-minute tour ×
ExpressionEngine® Answers is a question and answer site for administrators, end users, developers and designers for ExpressionEngine® CMS. It's 100% free, no registration required.

Having an issue logging back into the control panel after having been logged out. When attempting to login, I am returned to the login screen with no error messages or other notices. The only way I am able to log in is using an Incognito browser window.

I am using EE v2.5.2 with MSM installed.

UPDATE: I know this typically resolves itself after some time, but is there a known workaround so clients don't have to wait hours before being able to edit their content? Is this just an EE bug?

share|improve this question
    
I've had this problem but only when using Chrome. It usually resolves itself after a couple of hours. –  CreateSean Nov 26 '12 at 18:47
3  
Clearing cache and cookies has fixed this for me in the past. –  mjr Nov 26 '12 at 19:05
    
Did any of the answers help you? If yes, please mark the answer correct by clicking on the checkmark to the left of the answer. –  Anna_MediaGirl Dec 22 '12 at 6:25
add comment

5 Answers

up vote 10 down vote accepted

Clearing cookies should get around it.

You might want to look at your cookie settings in the CP and try switching cookies/session authentication.

I was having the same problem with an MSM site. I changed my CP session type to "Sessions and Cookies" and all now seems well.

share|improve this answer
add comment

The reason for this login issue still isn't clear to me after so many years.

My first suggestion is to clear browser Cookies and Cache.

The second step is to add the following into your config.php file:

$config['cookie_domain'] = "";
$config['cookie_path'] = "";
$config['cookie_prefix'] = "";
$config['admin_session_type'] = "s";
$config['user_session_type'] = "c";
$config['require_ip_for_login'] = "n";
$config['require_ip_for_posting'] = "n"; 
$config['secure_forms'] = "n";  
share|improve this answer
    
Do you know anything about why these settings work? What does the cookie path and domain do? What does admin_session_type do, and what are the possible values? It should also be noted that some of those settings, like require IP and secure forms, open up security holes on your site. –  kgrote Apr 30 '13 at 19:19
    
Here is what I have in my bootstrap config: d.pr/n/MIQp –  Paulo Elias May 24 '13 at 16:11
    
I should note when I ask "what do they do?", I mean, "what do they do to fix the login problem?" –  kgrote May 24 '13 at 16:21
1  
@kgrote Some explanations: cookie domain sets the domain to which the cookies apply. If you've got an issue, sometimes it's because EE's default guess about what domain it should use is wrong. I actually recommend never leaving it empty; always set it to the actual appropriate domain, as follows: .domain.com (note the initial dot!) Cookie prefix prefixes the cookie names with a value, so there aren't collisions if other things are also setting cookies (like the exp_ table prefix does for your db tables.) –  adrienne May 24 '13 at 18:27
    
@kgrote Cookie path makes the cookies only available from certain subdirectories; always leave it blank without a really good reason. The possible values for admin_session_type are 'c', for cookies only; 's' for sessions only; or 'cs' for session & cookies. It controls what type of security is used when logging into the control panel. The same values also apply to user_session_type, which controls security for ALL user logins. –  adrienne May 24 '13 at 18:29
add comment

I've had very good luck with setting a specific cookie prefix for every site in the MSM. This can be done via the control panel (Admin › Security and Privacy › Cookie Settings), or you can set it within the config file:

$config['cookie_prefix'] = "site_shortname_";

I'd recommend against leaving cookie_domain and cookie_prefix blank, especially if your MSM sites are subdomains on the same domain (e.g. site1.domain.com, site2.domain.com, etc.). I suspect that @MediaGirl is having luck with leaving those blank because she's forcing the admin login to use sessions only with $config['admin_session_type'] = "s";

share|improve this answer
    
This sounds like a great suggestion, but I am not able to make this work. Since there is only one config file setting it there sets the cookie prefix for all MSM sites doesn't it? Also, attempting to set it in the control panel for each MSM site just writes the most recent one to config.php, thereby setting it for all the MSM sites the same. Just wondering if you have any insight, Mark. Am I missing something? –  Alex Kendrick Jan 25 '13 at 17:23
1  
Try setting these config variables in the index.php of each MSM site: $assign_to_config['cookie_domain'] = 'site1.domain.com'; $assign_to_config['cookie_prefix'] = 's1_'; I'm using a master config file to accomplish something similar on my MSM setup, but I think updating the individual index files should work also. –  Mark Drzycimski Feb 5 '13 at 3:37
    
Thanks for the reply, Mark. I should have mentioned...I did try that. It seems that there is no effect. For example I tried using $assign_to_config['cookie_prefix'] = "foo_"; in the index.php file. This is EE v2.5.2. Not sure what I'm missing. –  Alex Kendrick Feb 5 '13 at 3:42
    
Cookie_domain is way more important than cookie_prefix for preventing this issue. –  adrienne May 24 '13 at 18:33
add comment

Always, always set a cookie_domain in your config. That fixes the problem every time I've ever had it. However, do not leave it empty! Set it to the actual appropriate value, as follows:

$config['cookie_domain'] = ".domain.com";

(Where domain.com is actually your domain, obviously!) Note the initial dot; that's important.

I would also usually set both admin and user session types to use both session & cookies, as follows:

$config['admin_session_type'] = "cs";
$config['user_session_type'] = "cs";
share|improve this answer
add comment

I had a similar problem after installing Zoo_Visitor module, to top it off I tried to login over 4 times unsuccessfully I triggered the "Admin->Session and Security Preferences" I had set to 60 min "Time Interval for Lockout." Lame...

To fix this... - I logged into my server and PHPmyAdmin db. - I went into the "exp_password_lockout" table and deleted the info in there. - After that I was able to try an log in again, but for some reason my username and password I've been using still wouldn't work.

When I installed Zoo_Visitor module my Username changed to my Email address. Light Bulb!

I tried my email address in the "username" field, same password and WHAMMY -> problem solved. Good thing because I was about to toss my computer out the window, I hope this helps you out.

-cr

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.