The process of identifying and fixing bugs in code.

learn more… | top users | synonyms

0
votes
2answers
42 views

If Any Channel Entries tags - webpage unavailable

I've inherited a site from another developer and a very strange hosting setup (moving to a new host as soon as I can get the site working locally). I've finally managed to get the site almost working ...
0
votes
0answers
16 views

Issues with url paths

I'm having an issue with loading CKEditor for Wyvern. No idea how this is happening, but the themes URL is doubling up: ...
0
votes
1answer
23 views

Using Template Debugger with RSS

I have an RSS feed that's taking a long time to process and would like to use the Template Debugger to help me isolate which parts of it are consuming time. The problem is, all the Template Debugger ...
3
votes
2answers
192 views

How to find the source of awful queries generated by EE

One of our sites has been really suffering and our ISP pointed out that we needed to optimize our templates because we were generating some really slow queries. For example this: SELECT ...
1
vote
1answer
34 views

Antenna plugin - bracket being inserted

I'm using the Antenna plugin to display a YouTube video on a website. The strange thing is that there's a close bracket ')' being inserted after the video. I can't for the life of me figure out where ...
0
votes
0answers
16 views

Template Debugging for Non-Administrator

Is there a way to turn on Template Debugging even if you are not an administrator? I have lots of pages that need debugging and they can only be accessed by users which are of the member group ...
1
vote
1answer
33 views

Better debug output

I'd like to know if there is any way to output the document's source before any of it is rendered. This would mean retaining all tags, markup, and code: PHP, HTML, EE tags, scripts, etc to see the ...
0
votes
1answer
50 views

WSOD on index.php and system, no problem reaching phpinfo

I have migrated my EE 2.5.1 install to a new dev machine (actually just OS - Ubuntu 13.10 - reinstall from scratch) and cannot get past WSOD in home or system. I checked the instructions from the ...
2
votes
2answers
466 views

Can't log in to Admin CP after updating from 2.6.1 to 2.7.3

I've just finished updating my EE installation from 2.6.1 to 2.7.3 but now that the update is complete I cannot log in. I can access the login page but when I enter my credentials it tries to load ...
2
votes
2answers
51 views

Difference between Template Parsing Finished and Total Execution Time in Debugging

I'm having major performance issues and I'm trying to nail down the culprit. I'm on EE 2.7.1 with a number of add ons (All of P+T's, Structure, ect.) However, I'm getting pages loads in excess of 5 ...
1
vote
2answers
54 views

Having issues with $config['debug'] = “1” and environments

I currently have environment variables in my config.php file to deal with databases but on the last couple of project I've had to turn on debug on more than one occasion. I added $config['debug'] = ...
2
votes
2answers
129 views

Turn profiler and debugger off for specific templates (called via AJAX)?

I have a page where I'm calling several separate sections via ajax. When I am logged in each of these sections pull in their own "version" of the profiler and debugger. Is it possible to disable in ...
4
votes
2answers
228 views

How do I capture *all* data from a White Screen

I have a live e-commerce site which is seemingly random (in that all the reports appear to be different) error where, at some point, during the checkout process, the entire thing gives up and I get a ...
3
votes
3answers
161 views

What are the recommended ways to get to the bottom of slow load times in EE?

I'm experiencing some really slow load times with my EE install. Other sections of the site that aren't managed by EE are loading very quickly, but any time I hit an EE-managed section it takes at ...
1
vote
1answer
95 views

CP loads slow once in a while

I have transfered a site to a new server and at the same time incorporated Focus Labs Master Config approach. Now, since the site is running on the new server the CP loads really slow sometimes. It ...
1
vote
1answer
179 views

Error Number: 1064, ExpressionEngine 1.7.3 Chrome Bug

I am getting the following error in Chrome for my site: MySQL ERROR: Error Number: 1064 Description: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server ...
1
vote
0answers
66 views

Template debugger not outputting information about add-ons

I have Template Debugging and Output Profiler turned on for my site, but i'm not seeing any debug information about my add-ons being used on the site. On any other site it would show what's happening ...
5
votes
1answer
50 views

What does a slow “Parsing Segment, Embed, and Global Vars Conditionals” log entry mean?

I'm working on getting EE installed on Google Appengine's new PHP runtime. Things are slow, and I'm trying to identify why that might be. I've disabled most add-ons, and created an EE tag-less ...
0
votes
0answers
45 views

Debug not outputting content

We're trying to debug a site with multiple routing problems. We obviously need the debug profile to see what templates are being parsed and when. However, the results are not being shown on the front ...
5
votes
1answer
209 views

Re-writing Playa tags to disable the Playa extension for better site performance

With the overall goal of reducing page load time (Memory, Execution Time in template debugging), how can I rework my Playa templates so as to “shut off” the Playa Extension? Template debugging shows ...
3
votes
2answers
236 views

Module tag pair not working

I'm trying to create a module tag but it just isn't working, I'm following the Hello World tutorial at Ellis Lab. My module is installed and the MCP part is working. Here is my mod file: <?php if ...
2
votes
1answer
130 views

Template Debugging - I can't see it

I've enabled template debugging on our EE installation on a test server. I can't see the template debugging information when I load pages (either in CPanel or templates). Another developer I work with ...
0
votes
3answers
123 views

Problem with custom global variable

I created a custom config file with my own global variable. When I'm using the EE debugger, I have an output of my global variables: So, I guess, they exists and I can access to them. The problem ...
6
votes
3answers
63 views

Why am I getting different results from the template debugger locally to live

Why would the MB size on Begin Template Processing be so much different on a site hosted locally to that same site being put on a live server? And does that have any relevance to page speed? An ...
0
votes
2answers
349 views

Minimee not working. How do I display template debugging?

I've installed Minimee. It doesn't seem to be combining CSS and JS files, despite them being wrapped in {exp:minimee:css} and {exp:minimee:js} respectively. Minimee is installed and "Combine Assets" ...
6
votes
3answers
254 views

Database Queries in Output Profiler Won't Display

With template debugging enabled, clicking the "show" link to display the database queries isn't working. I suspect this is related to the fact that on all pages of this site there are 7 chunks of ...
6
votes
1answer
1k views

PHP error logging: force to always log errors to an error file

My ideal situation would be to always log errors to file, but only display errors to logged in Super Admins. This way I'll be able to tell if my users are triggering PHP errors even if they aren't ...