0

I'm having trouble getting my P&T Checkboxes field to display properly.

My field is {job_type} and it's options are: full_time : Full-time part_time : Part-time

This is the code I'm trying to use, but it doesn't ouptut anything:

{exp:channel:entries}   
  {job_type backspace="2"}{option}, {/job_type}
{/exp:channel:entries}

If I change it to just {job_type}, it outputs the selected value as part of a list; but if I try to use the proper :ul tag, {job_type:ul}, it doesn't output anything.

I'm using EE 2.5.5, and P&T Checkboxes version 1.0.3.

3

To get the tag pair to work with EE 2.5.5 and PT Field Pack 1.0.3 you need to modify the ft.pt_checkboxes.php file and add has_array_data = true;

class Pt_checkboxes_ft extends PT_Multi_Fieldtype {

var $info = array(
    'name'     => 'P&T Checkboxes',
    'version'  => PT_FIELD_PACK_VER
);

var $class = 'pt_checkboxes';

var $has_array_data = true;
0

artmem,

I just tested this. I have a checkbox (pt_checkbox) with three options. I threw this into a template to test the output:

    {exp:channel:entries limit="1"}
<h1>{title}</h1>
    {pt_check}
    {option_name}: {option}<br />
    {/pt_check}
<hr />
{/exp:channel:entries}

<hr />

{exp:channel:entries limit="1"}
<h1>{title}</h1>
{pt_check:ul sort="asc"}
{/exp:channel:entries}

and both sets of tags gave me the correct output, as:

Screenshot of Output

Does a very simple test like that work for you? I'm also testing on 2.5.5 and 1.0.3.

5
  • I tried it. Your second example (the UL tag) did work, but the first, with the tag pair gave no results.
    – artmem
    May 7 '13 at 22:13
  • That is a bit odd. Are you able to upgrade to Field Pack 2 for further testing? If that doesn't get this working, I'd be happy to login and do some direct troubleshooting. :)
    – Lisa
    May 7 '13 at 23:34
  • I tried to upgrade to Field Pack 2, but I can't get it to install. I uploaded the files to the proper locations, but when I go to my Fieldtypes page in the CP to install them, they don't show up. I've moved my third_party outside of the system folder. Could that be an issue? I haven't had any problems with other add-ons.
    – artmem
    May 8 '13 at 20:34
  • What do you have set in your config for the third_party path? If you'd like me to look at this directly, Super Admin and FTP details to support@pixelandtonic.com would be ideal.
    – Lisa
    May 8 '13 at 21:02
  • Just emailed login info & details.
    – artmem
    May 8 '13 at 21:16
0

Field Pack 2.0.2 requires EE 2.6 at least. Having same issue with EE 2.5.5 and fieldpack 1.03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.