1

Currently working on a site that will be making audio files available to their membership. My Resource channel has a Channel Files field ("Audio") to upload such files. Originally I was going to upload these files to a folder above root for additional security. When that didn't work, I changed it to a regular folder within the site. That still doesn't work.

When I try to upload a large MP3 file (~ 20-25MB), it goes all the way through the process, then I get an error that says

Upload request failed, no HTTP 200 Return Code! OPEN ERROR

When I open the error, I simply get a message that says

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

I tried skipping Channel Files and tried to upload the same file through File Manager, and also got the "Internal Server Error" message.

This is on a dedicated server, so I have full access to everything. My php.ini settings show

asp_tags = Off
include_path = ".:"
ignore_repeated_source = Off
variables_order = "GPCS"
track_errors = Off
output_buffering = 4096
auto_globals_jit = On
doc_root = 
log_errors = On
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
auto_append_file = 
disable_classes = 
display_startup_errors = Off
user_dir = 
enable_dl = Off
register_argc_argv = Off
display_errors = Off
open_basedir = none
allow_call_time_pass_reference = Off
safe_mode_exec_dir = 
default_socket_timeout = 60
html_errors = Off
register_globals = Off
unserialize_callback_func = 
y2k_compliance = On
magic_quotes_runtime = Off
expose_php = Off
log_errors_max_len = 1024
post_max_size = 150M
report_memleaks = On
engine = On
memory_limit = 128M
short_open_tag = On
max_execution_time = 800
safe_mode_include_dir = 
serialize_precision = 100
precision = 14
upload_max_filesize = 150M
register_long_arrays = Off
safe_mode = off
zlib.output_compression = Off
ignore_repeated_errors = Off
request_order = "GP"
default_mimetype = "text/html"
allow_url_include = Off
disable_functions = 
file_uploads = On
magic_quotes_sybase = Off
max_input_time = 800
magic_quotes_gpc = Off
error_reporting = E_ALL & ~E_DEPRECATED
safe_mode_gid = Off
auto_prepend_file = 
implicit_flush = Off
allow_url_fopen = On

I tested it with uploading a 5MB MP3 file and some smaller .txt and .wav files.

Anything obvious that I'm missing or could try?

Thanks!

  • Your memory limit is set lower then your upload limit. Not sure if that would affect anything. – stuartmcd69 May 8 '13 at 5:51
  • Thanks for the suggestion. While I'm on a dedicated server, my changes don't seem to be taking effect. So I'm working with my host to change it and see if that makes a difference. Seems like it's always one step forward and two steps back! :( – Todd May 8 '13 at 16:55
1

OK, thanks to a persistent support team at my host (Codero), they were able to track down the issue. They said since I was running PHP through FastCGI, it was an Apache error that was causing the problem. They made changes to the domainvirtualhost.php file and I am now able to upload 35MB + files.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.