1

I have a textarea field (which i'm using to paste some custom CSS for a page) that has no formatting set on it.

However, when I paste the following in;

h2 {background-color: #03c7e1;}

ExpressionEngine automatically outputs it as;

h2 {background-color: #03c7e1;}}

It's real confusing and wondered if anyone else had this issue before?

2
  • What's the field set to - none, xhtml... ? – stuartmcd69 May 8 '13 at 13:00
  • It's set to 'none' :/ – doubleplusgood May 8 '13 at 13:01
1

Make sure to check the particular Channels preferences

admin > channel administration > channels >

Edit the preferences for the channel in question and look for "Channel Posting Preferences" and in particular "Default HTML formatting in channel entries" - set this to: "Allow ALL HTML". I suspect it may be set to: "Convert HTML into characters entities"

1
  • Thanks Stuart. Seems it was already set to "All ALL HTML". :/ – doubleplusgood May 13 '13 at 12:30
0

} is the HTML character entity for a right curly bracket }. It could be that you've forgotten to include a closing curly bracket somewhere in the code you're pasting in and it's being interpreted incorrectly as a result. Check your code in that textarea and ensure all brackets are paired up correctly.

If everything matches up correctly in your textarea field then it might well be in your template where a mis-match is causing the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.