1

For the time being, I'd like to set my store to allow shipping only to UK addresses, but I'd like to accept payments from everywhere (so people can send gifts to those in the UK).

I have only two shipping methods: Free shipping (which will later become a flat fee) and Collect In-Store. Both of these are set/apply to UK only, but my overall Countries/Regions has all countries enabled. This isn't achieving what I want, as every country is selectable on Checkout2 under Shipping Details.

How do I exclude all other countries from shipping but not billing?

0

Just hard code the shipping address in your template:

<!-- shipping address, city, etc here -->
<p>
  Shipping Country: United Kingdom<br>
  <small>Sorry, we are only able to offer shipping to the UK at this time.</small>
  <input type="hidden" name="shipping_country" value="gb" />
</p>
0

If shipping and collection is only to the UK then just hide the country select box from the Shipping Address section and ensure that the Regions listed are those within the UK.

You can either hide the field with a little CSS in display: 'none' or simply hide the input field with by adding input type="hidden".

Whilst posting this I see that Adrian has mentioned that latter. :)

In Store > Settings > Countries/Regions make sure all the UK regions are listed and correct. These are derived from EE itself and they were out of date prior to the latest release (2.6). I submitted a request a while back to have them updated and have been told they've made it into the latest release but haven't checked them yet.

  • Thanks for your great advice, Ian! I really appreciate it. – Alissa J. Robinson May 9 '13 at 14:11
  • Yes, version 2.6 of EE removed the incorrect country code "UK" (it should be GB). However some people had already enabled that country (and it doesn't really hurt anyone unless you are using external shipping calculators), so as long as you're running Store 1.6.4 it will assume UK is still a valid country code and everything will work smoothly. – Adrian Macneil May 9 '13 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.