1

I recently installed a version of EE on my local machine(Mamp Pro), v2.5.5 - Build Date: 20121220. I set this site up as per usual and started building my initial site templates etc ready for the master site which would encompass all the other child sites with MSM.

I then installed MSM by buying the software license and then enabling it in the main general settings of the cp in my site. I then created a new sub domain with MAMP PRO and then added a folder in it with index.php and admin.php, I then changed these settings in each:

index.php

$system_path = '../build/system/';
$assign_to_config['site_name']  = 'mysitename'; 
$assign_to_config['cp_url'] = 'http://missns:8888/admin.php'; 
$assign_to_config['site_url'] = 'http://missns:8888';

admin.php

$system_path = '../build/system/';
$assign_to_config['site_name'] = 'mysitename';
$assign_to_config['cp_url']    = 'http://missns:8888/admin.php';

When I try to access

http://missns:8888/admin.php or http://missns:8888

I get this error:

Site Error: Unable to Load Site Preferences; No Preferences Found for: mysite

Then in my main cp site theme where my main site is installed I go to the top right of the site and click my master site name and click 'edit sites', I then just get a server error page that takes me out of my site, it basically blows up.

  • As a side note if you're using MAMP Pro you don't need to add the port number to the URL if you go to Server > Apache and set the port to the default web port (80). – Ian May 9 '13 at 11:54
1

Have you set things up following the instructions in EE docs?

Ensure that you have the relevant permissions on to allow access to your installations system folder:

The new folder must allow files within it to access your installation’s system folder. Check with your host to ensure you don’t have “open_basedir” or other restrictions in place which could prevent this.

Also, maybe try providing the virtual host name if you're setting this up locally. So instead of:

$system_path = '../build/system/';

Try:

$system_path = 'domain1.com/system/';

Where domain1.com is the name of your local virtualhost.

Also, make sure you make the changes to both sub domains as indicated in the docs.

| improve this answer | |
  • Should I change $system_path in my main index.php file where I did the main install of ee as well or just the subdomains folders? I have been through the install so many times so I know it must be right. – M dunbavan May 9 '13 at 12:30
  • Are you sure you've copied the relevant files first? Apologies if you have but with only a snapshot of what you may or may not have done it's always best to make sure the basics are covered first. – Ian May 9 '13 at 17:14
  • oh yeah all of that was done yes! – M dunbavan May 10 '13 at 8:38
  • 1
    Did you resolve this, I have similar issues. – paulcripps Nov 24 '15 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.