4

I have a Zoo Visitor form that populates a channel entry. All is well in that it actually submits the content. However, the strange thing is I would have no way of knowing that until I check ExpressionEngine's control panel and seeing that the edits have been made -- because the browser hangs the moment I press submit. It looks like it's perpetually loading. Then trying to go anywhere else on the site makes it super super slow.

When I close the browser and visit the form again, everything loads fast on the site. But when I make a change in the form and press enter, again, browser hangs forever even though it looks like it submitted in EE. It never goes to the /success/ page.

Help?

1
  • I also stripped the template & form down to its bare bones, just the update form and 3 text inputs, no styling. Still hangs. – lealea May 14 '13 at 0:09
4

The most likely culprit is an extension using the entry_submission_end hook (http://ellislab.com/expressionengine/user-guide/development/extension_hooks/api/channel_entries/) that is getting hung up. (It'd be after the entry_submission_start/ready hooks, since it's saving the entry)

Your best bet is to disable all the extensions, and to see if the problem persists.

1
  • That would coincide with MX Notify Control (which she is using) too. I am curious to see which one it ends up being the problem. – Justin Kimbrell May 14 '13 at 0:44
2

I disabled MX Notify Control and everything began working again. It looks like that was the culprit!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.