4

Given a Playa field in Low Variables called widgets, how would I output the title of each widget? Below is what I'd expect, but it outputs nothing.

      {exp:low_variables:parse var="widgets"}
        {title}
      {/exp:low_variables:parse}
  • Can you perhaps add screenshots of the Widgets variable type settings, the variable in LV itself and any output from the Template Debugger that mentions the LV tags? – Low May 15 '13 at 10:52
  • @Low, I'll email the screenshots and post a solution back here, if we/I find one. – Matt Fordham May 15 '13 at 15:38
4

I fixed this issue. It was/is a bug in Playa. Pixel and Tonic now knows about it and will include a fix in the next release. In the meantime, here is my solution:

Change Line 2484 of ft.playa.php to...

$data = array(
'parent_var_id' => $this->var_id,
'parent_is_draft' => 0
);  

Basically added 'parent_is_draft' => 0

| improve this answer | |
1

I'm just confirming that this works in Playa 4.4.4 + Low Variables 2.3.5 with EE 2.6.

| improve this answer | |
0

Matt,

Have you seen Low's answer? His first example should work for you:

{exp:low_variables:pair var="lv_settings_home_feature_items" limit="3"}
    ...more code here...
{/exp:low_variables:pair}

If it's not working, can you post your EE version, Playa version, and LV version?

Thanks!

-Lisa, P&T

| improve this answer | |
  • Yeah, that's pretty much exactly what I did, but no luck. – Matt Fordham May 14 '13 at 21:43
  • EE 2.5.3, LV 2.3.5, Playa 4.4.2 – Matt Fordham May 14 '13 at 21:43
  • I can reproduce this and will ask one of my devs to have a look. Thank you Matt! – Lisa May 15 '13 at 19:15
  • I'm seeing this also, using EE 2.6.1, LV 2.3.5, Playa 4.4.3. – Dylan T May 16 '13 at 0:44
  • I am running into this issue as well using EE 2.6.1, Playa 4.4.5, and LV 2.4.0. The single low variable is returns a proper array -- for example, {var_name} returns an array like "[10] [this-is-a-stand-in-title] This is a stand in title". However, wrapping in a tag pair is returning no results -- for example {exp:low_variables:pair var="var_name"}...code...{/exp:low_variables:pair}. Is this reproducible for anyone else with this setup (knowing that Playa 4.4.4 addressed this issue)? – Shanan Galligan Sep 11 '13 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.