The problem I'm having is that I can't log in to the control panel. When I enter my login details, the page just refreshes. No error message, just a page reload. It does this repeatedly, so can't get in at all at the moment. This happened after upgrading from 2.5.5 to 2.6.1, but also happens on a fresh install of 2.6.1, so I don't think it's down to my particular installation.

I have been getting this error intermittently on EE 2.5.5. Today I upgraded to 2.6.1, which meant I couldn’t login 100% of the time, so I’ve rolled back to 2.5.5 for the time being until this is fixed

EE Version: 2.6.1 Browsers tried: Chrome, Firefox, Safari, all most recent versions Development Environment: localhost apache 2.2

Any ideas? I've tried changing the session & cache variables, clearing the cache, running in incognito mode... No idea what's going on.


Update - Top of my config file looks like this:

$config['app_version'] = "261";
$config['install_lock'] = "";
$config['license_number'] = '';
$config['debug'] = "0";
$config['cp_url'] = 'http://local.sitename.com/admin.php';
$config['doc_url'] = "http://ellislab.com/expressionengine/user-guide/";
$config['is_system_on'] = "y";
$config['allow_extensions'] = 'y';
$config['site_label'] = '****';
$config['cookie_prefix'] = 'sitename';
$config['cookie_domain'] = '';
$config['cookie_path'] = '';

I am using an NSM config bootstrap file though, let me know if any of those settings could be breaking it too...

  • If Jim's answer doesn't help, what does the top of your config.php file look like? Commented May 21, 2013 at 18:13
  • Thanks Stephen. No result from setting a cookie domain or from deleting all my cookies. I've updated my question to include the top of the config file. Commented May 22, 2013 at 20:29

5 Answers 5


You may be experiencing the problem from this bug. https://support.ellislab.com/bugs/detail/19334

Give the suggested fix a try and let us know if that helps you.

  • 1
    Thank you so much! It doesn't seem to have been directly editing the core file, but one of the comments further down the list named Structure 3.3.8 as the culprit. In my case, disabling "Redirect on login" in structure seems to have fixed the issue. Thank you for pointing me in the right direction, would never have found that. Commented May 22, 2013 at 22:06
  • 3
    Additionally, for anyone else struggling with this, I managed to get in to change that option in structure by changing "$config['allow_extensions'] = 'y';" to "$config['allow_extensions'] = 'n';" Commented May 22, 2013 at 22:27
  • Having said that, now I'm being signed out almost immediately, but that's obviously down to something else.. sessions not being long enough or something. Commented May 23, 2013 at 9:16
  • Ugh. That sucks. If you need further help, I'd suggest asking a new question with the current problem. Commented May 23, 2013 at 9:25
  • I searched half the web and couldn't find an answer until I read your comment @darlyknight - thank you. It was the Structure redirect. Commented Mar 26, 2014 at 20:39

Try deleting all your domain and session cookies. This happens to me from time to time when I have logged in to numerous different EE sites in the same browser.

  • Hey, thanks - I cleared everything from Chrome (& other browsers) including cookies & cache. Assume this should have the same effect? Still getting the same problem after doing that. Commented May 22, 2013 at 8:28

Crossed cookie wires are usually the cause of this problem. The best fix for this is to clear your cookies, then set a custom cookie prefix in config.php:

$config['cookie_prefix'] = 'sitename';

This also has the added advantage of improving security on your site, because a visitor won't be able to tell that you're using ExpressionEngine based on your cookies.

If you're using Focus Lab Master Config, it's a good idea for your cookies to be different for each environment, or you'll get crossed wires again. So for that you'd use:

$env_config['cookie_prefix'] = 'sitename_' . ENV;

Where ENV is the variable Master Config uses to identify which environment you're currently in.


I was getting this problem on a local development machine and realised that I needed to update the value of cp_url:

$config['cp_url'] = "http://MY-LOCAL-MACHINE/system/index.php";

EE appears to use this URL to determine the cookie domain, and so cookies were being set to the wrong domain.


Just had a similar problem on an old (EE 2.3.1) site. In my case it happened after a database crash. I had to manually clear out exp_online_users and exp_security_hashes.

The symptoms for me were that trying to log into the control panel just did the page refresh thing with no error. When I tried to log in through the front end I got a SQL message saying something about trying to add a duplicate entry to exp_online_users. So I cleared out that table manually. Then trying to log into the control panel would surface an error talking about duplicate exp_security_hashes. Once I cleared that out, everything worked.

This is probably only applicable in a similar case as the one we found ourselves in. The database server hard crashed, I guess. Took the ISP several hours to get it up again so I assume it was a major problem on their end.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.