3

This one is causing me a headache and I am pulling my hair out! Anyone done this before?

I have MSM set up and want to keep site 1 managing all the products. I am then using categories to only show the desired products on each site.

• Products are showing up fine on both sites.
• On site 1, everything is working ok. Products are adding to cart.
• Site 2 adds the product to cart, but it has a zero value.

I have tried:
• If I hard code a price="" in, it works and adds that value to cart.
• I have set up cookies properly for each site and there is no cross contamination there.
• on_the_fly on site 2 has the same £0.00 effect - also the entry ID is being picked out
• Check to see if global prices are zero
• plus everything I can think of.

I am presuming that because I have no product mapping in site 2, that it is breaking there. Does anyone know of a way to maybe manipulate the db to show one channel in both sites?

Any guidance would be greatly appreciated as I am now bald.

Thanks in advance.

5
  • What version of EE and CT are you running? Do you have MSM setup as a sub domain or domain? Is it all done by the book or are there any modifications made along the way?
    – Ian
    May 29 '13 at 11:53
  • Hi ya Ian, thanks for the support. EE 2.6.1, CT 2.3.21. Site 2 is on a separate domain. MSM is working well. I am running some pretty heavy custom configs to manage deployment. cookies are setting ok in the various domains. is there something else you think I should be looking for? Thanks again for the help.
    – T2theC
    May 29 '13 at 12:19
  • It's a tough one as it's not easy to try and replicate the setup unless you have MSM and CT setup in the same way. Has there been no luck in contacting CT?
    – Ian
    May 30 '13 at 13:09
  • I think I'll have to try them. The support seems to have dropped off recently. Thanks for your effort Ian. I'll give them a go and see what comes of it. Cheers.
    – T2theC
    May 30 '13 at 15:52
  • This looks like it's most likely an issue with the compatibility between Safecraker (latest) and the latest version of EE. They're behind in rolling out the fixes so the best thing for the time being would be to roll back to EE 2.5.x if possible. Or if it's not critical then you could wait on a fix from CT but that's an unknown timeframe at the moment.
    – Ian
    May 31 '13 at 10:22
1

Apologies if this seem obvious - and it will get more complex if you have price modifiers, etc, then requiring use of an extension hook and more logic - but why not just hard code the price with the price field's value?

{exp:cartthrob:add_to_cart_form allow_user_price="y" price="{product_price}"}

(This still excludes using the simpler add_to_cart tag, which just accepts an entry_id.)

0

Thanks Derek for your response. I had gone down that avenue and the price modifiers was one issue. I also have ad odd set up as there are four channels for different products. So depending on the channel, I have to run a {if} on the pricing. I ran into a parse order problem with this.

I have found that it IS actually something to do with the session being set. Oddly, if I am logged out, the product adds to cart as 0. If I then log in, and take a look at the cart, the price is set correctly.

I am revisiting this now to see how to fix it. Its an odd one!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.