2

I just can't get the Freemember registration form to work. I'm using the default form from the docs:

    {exp:freemember:register return="login" error_handling="inline" error_delimiters='<span class="error">|</span>'}

    <p>
        <label for="email">Email</label><br />
        {field:email}<br />
        {error:email}
    </p>

    <p>
        <label for="password">Password</label><br />
        {field:password}<br />
        {error:password}
    </p>

    <p>
        <label for="password_confirm">Confirm Password</label><br />
        {field:password_confirm}<br />
        {error:password_confirm}
    </p>

    <p>
        {field:accept_terms} <label for="accept_terms">Accept Terms</label><br />
        {error:accept_terms}
    </p>

    <p>
        <input type="submit" value="Submit" />
    </p>

{/exp:freemember:register}

The form sends but nothing happens. I'm not sure what to even do to get this to set up and work properly. Do I need certain settings I'm missing in member preferences? When I use the default EE member/registration form it works just fine.

EE 2.6.1 Freemember 2.2.2

5

There is most likely an error being thrown but not being displayed. A few things to check...

Double check that it's installed correctly and listed in Addons > Modules.

Then ensure that you have set your encryption key in system/expressionengine/config/config.php.

The next thing to try would be to remove error_handling="inline" so you can see any errors that are returned on form submission.

You're also including accept_terms in your registration form. In Members > Member Preferences, look for "Require Terms of Service". It could be worth setting this to 'No' to test with. You could even try removing that from your form if you set this 'No'.

Does any of that help to shed any light on things? Are there any errors returned?

|improve this answer|||||
  • It seems that getting rid of the accept_terms and shutting it off in member prefs did the trick. However, no email is submitted, I have "self-activation via email" set. I also get an "error loading page" from my return url. Looks like i made one step forward, but more hurdles lie ahead still. – Andy May 26 '13 at 17:50
  • The return URL just needs to be set to an active URL in a template_group/template pattern as usual. If login doesn't exist then it will return an error. – Ian May 26 '13 at 17:54
  • In terms of the email. That could very well be your email settings in Admin > Email Configuration. What protocol are you using? – Ian May 26 '13 at 17:56
  • 1
    Probably best to set up sendgrid (free for low volume) to send your mail from your development server, to rule out any delivery issues. Freemember actually doesn't have anything to do with the member registration emails, these are sent automatically by EE when the member is created. – Adrian Macneil May 27 '13 at 10:24
  • 1
    Andy, you want to mark this as answered, so that the answerer gets his points, right? – narration_sd May 27 '13 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.