1

My situation: I have 3 sites (2 photoblogs, 1 start page). The 2 photoblogs use Assets to manage the images and CE Image to make the thumbnails.

My problem: on the start page i use (this is a simple example just to get the URL from assets in their respective entries for all sites):

{exp:channel:entries channel="fotoblog" site="site1|site2" limit="1"}
 {fotoblog-imagens limit="1"}{url}{/fotoblog-imagens}
{/exp:channel:entries}

{fotoblog-imagens} is an Assets field

Only site1 returns the URL. Site2 doesn't. If i erase Site1 from the site field, it now returns the URLs for the Assets in entries on Site2. Tried var_prefix but results are the same. Any tips?

4
  • Vitor - can you add some version numbers? EE, Assets, MSM? Thank you!
    – Lisa
    May 27, 2013 at 17:13
  • EE - 2.6.1 MSM - 2.1.5 Assets - 2.1.3
    – Vitor
    May 28, 2013 at 6:27
  • That should not be a problem. Is Wygwam involved here at all? Are login details to your site available by any chance? Super Admin access specifically. If so, can you email those to [email protected] so that I can look directly? Thank you!
    – Lisa
    May 28, 2013 at 18:03
  • Wygwam addon is installed, but it's not called. just expressionengine entries and Assets. I've sent you guys an email.
    – Vitor
    May 29, 2013 at 6:04

1 Answer 1

1

I think what you'll need to do is add site_id="site1" to your assets loop.

{exp:channel:entries channel="fotoblog" site="site1|site2" limit="1"} {fotoblog-imagens limit="1" site="site1"}{url}{/fotoblog-imagens} {/exp:channel:entries}

I think that should get it working.

3
  • I'ts a bug in Assets module. Pixel and Tonic has solved. The fix will come on the next update (currently 2.1.3)
    – Vitor
    May 31, 2013 at 10:55
  • I'm unable to get this to work. Can you provide correct template tags?
    – Jon Horton
    Jun 4, 2013 at 19:44
  • If you are replying to me Jon, I'd first update Assets. Victor mentioned that it was a bug. If you want to try the code I suggested, I am presuming you are replacing 'site1' with the short name of your site?
    – T2theC
    Jun 6, 2013 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.