4

I'm trying to sync my folders using the "Sync" feature in File Manager, but as soon as I press it, then on the next screen, hit Submit... I get the EE White Screen?!

Why would it do this?

It's only recently started doing it, but I've noticed it on a few sites I've deployed.

EE v2.4.0 - Build: date 20120123

  • 1
    Think we could use a bit more information. Have you tried enabling debugging? What do you see? – Kim Wickell Dec 4 '12 at 14:27
11

A white screen of death normally means that a PHP error has occurred but it's being suppressed. They should normally be shown if you are logged in as a superadmin but sometimes aren't depending on your config. Here's some things to try to make the error visible:

  • Go into your admin.php and change $debug to 1 instead of 0 (it's under "Error Reporting"). Ideally do this locally or else be sure to turn off after trying it
  • Go to Admin ‣ System Administration ‣ Output and Debugging and ensure that Debug Preference is set to 1: PHP/SQL error messages shown only to Super Admins.
  • Go to Tools ‣ Utilities ‣ PHP Info and search the page for “display_errors”. Ensure it is set to On under the Local column. If it is not, your host can help change this setting for you.
  • Go into your admin.php and change $debug to 1 instead of 0 (it's under "Error Reporting"). Ideally do this locally or else be sure to turn off after trying it
  • Alternatively inspect the PHP error log file on your server.

If you then see a PHP error, update your question with the details, or if none of this works then update with that info.

  • Thanks for all this Tom! I knew about a few of them, but didn't know about the admin.php error debugging. It tried doing all of this, but none of them worked. – Jason Mayo Dec 4 '12 at 15:20
  • How do I find the PHP error log? #noobquestion – Jason Mayo Dec 4 '12 at 15:40
  • it's location will depend on your environment - quickest way to find it is probably sticking a phpinfo() call in a php file in web root - it will be under error_log – Tom Davies Dec 4 '12 at 15:57
6

Another useful tip that I discovered recently is that you can actually override any @ suppressed errors via the xdebug.scream config setting. This isn't much use in production environments where you presumably won't have Xdebug installed (and you should be hiding any errors anyway), but if you add the following snippet to your local dev environment's php.ini you'll be able to debug even the most stubborn of white screens:

xdebug.scream = 1
  • 1
    I've never seen that before, nice one!! – JohnWBaxter Dec 4 '12 at 15:29
  • 2
    This just completely saved my arse. THANK YOU! – Paulo Elias Sep 6 '13 at 16:46
3

Something else you might want to look at is the amount of PHP memory. Often times upping the memory limit might help.

  • 1
    +1 This is actually a really good point - IIRC EE will do some image processing when you hit "sync" so for large upload directories memory_limit could well be an issue – Tom Davies Dec 4 '12 at 17:03
  • Great tip Sue. I was going to suggest increasing memory_limit in php.ini – Mel Dec 4 '12 at 17:30
  • I tried increasing the PHP Memory Limit, but no luck. – Jason Mayo Dec 19 '12 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.