Recently updated to v2.6.1 and I have an issue now where users are not able to edit content authored by other authors. In this case the user group in question has "Can edit entries authored by others" set to yes but whenever the user tried to edit it won't allow it. Any ideas?



  • Which version did you upgrade from and which member groups are they in? Is it a custom one or pre-existing?
    – Ian Young
    Commented May 29, 2013 at 18:28
  • I don't recall I think 2.5.x but not 100%. They are custom groups and it seems to be an issue when the users that authored the article don't have "Include user in PUBLISH page multi-author list?" checked.
    – Guy
    Commented May 29, 2013 at 18:55
  • An obvious one, has the member group allowed access o the channel?
    – T2theC
    Commented May 29, 2013 at 19:26

4 Answers 4


It is most likely that the correct permissions aren't set on the Member group to which the users belong to.

Go to Members > Member Groups, click on the member group in question and scroll down to the Channel Posting Privileges. Check these settings and ensure that Can edit entries authored by others is set to Yes. Save that and try again.

  • Yes the member group has access to the channel.
    – Guy
    Commented May 30, 2013 at 13:35
  • Ian thanks but already tried this and it is not the case. The group already has "Can edit entries authored by others" is set to Yes.
    – Guy
    Commented Jun 3, 2013 at 18:15

I'm having the exact same problem here. Upgraded from 2.5.* to 2.6.1 and my users in a custom group called 'beheerder' can't edit entries without setting a super-admin as the author of a page.

The super-admins are the only ones that show up in the dropdown field.

And yes, my 'beheerder' group has the right to the specific channel assigned to them and has been authorized to change entries posted by others.

enter image description here


I also have the problem with EE 2.6.1 I checked "Include user in PUBLISH page multi-author list?" as mentioned above, but users A can´t edit an entry from user B. But if user B changes the author from A to B, so that he´s the author, he can edit and save.

This is not really what I want.

The Member Account Privileges are correct for the entire memer group and the individual member.


I hit this same issue with 2.7.2, so posting in case it helps anyone else. I had two issues. One was that I had to change preferences for the editing Member Group to enable 'Can change the author name when posting channel entries', even though I am not changing the author. Second, I had to change the privileges of the original author Member Group to enable 'Can edit entries authored by others', even though it is their own record that is being edited on their behalf by the other Member Group.

Here is the code that was throwing the error for me, maybe when I have time I'll see if it's 'fixable':

    if ($data['author_id'] != ee()->session->userdata('member_id') && ee()->session->userdata('group_id') != 1)
        if ( ! isset($this->_cache['orig_author_id']) OR $data['author_id'] != $this->_cache['orig_author_id'])
            if (ee()->session->userdata('can_assign_post_authors') != 'y')
                $this->_set_error('not_authorized', 'author');

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.