1

This is a very weird problem.

I've tested all the steps of the checkout process and it works fine most of the time. By most of the time I mean, in the local environment, it works on Chrome, Safari & Firefox but on a live server such as the staging environment, it works on Chrome & Firefox but not Safari

I tested both my own template as well as the pre-installed examples and got the same results. No luck with Safari on Staging Env.

I've also tested on Safari & Chrome on iPhone & iPad & the same thing happened. Chromes works well but Safari just doesn't want to do its job.

I've tried all the solutions from this question but still no luck.

Here is some of my system info:
Safari: 6.0.4
EE 2.5.5
Expresso Store: 1.6.4

I don't think that there's any problem with the server though. have you ever experienced this issue? If yes, can you tell me where to start investigate?

Thanks!

5
  • What do you have in your .htaccess file? Is your staging server on the same host with exactly the same setup as the production server? When you say it's not adding products to cart, what is actually happenening? Any errors, a page refresh or any other feedback? – Ian May 31 '13 at 10:16
  • Hi Ian Here is my .htaccess file: cl.ly/PLJy What happened was not a page refresh. I actually was redirected to the checkout page but no product was added to cart. There was no errors or other feedbacks. Thanks! – Hung Q. Le May 31 '13 at 13:43
  • Is the product in question definitely not out of stock? – Adrian Macneil Jun 1 '13 at 23:30
  • @Adrian:They all have limited quantity and not out of stock. – Hung Q. Le Jun 2 '13 at 4:58
  • Do you have a link to your development site? As Store is server-side software there shouldn't be any browser-related differences or bugs, these usually turn out to be related to whether a user is logged in or not, or something similar, not the actual browser. – Adrian Macneil Jun 2 '13 at 9:31
1

At this point, I can confirm this is a server fault, the problem did not come from either Safari or Expresso Store. I've uploaded my local dev version to another staging server and everything appears to be working properly.

However, still need to investigate further to find out what really caused the problem since the current server is configured almost exactly the same as the one I just used to test.

Can anyone tell me what kind of settings I should check?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.