1

By 'stopped working', I mean that the prompt 'no rows exist yet - create the first one' appears, but clicking on it does nothing. Same for the '+' symbol - clicking on it does nothing.

Everything was working up to this point, and I can still add values to other fields for that Channel. I was able to enter values into columns in this particular matrix fields until recently, plus select entries in other columns using the Playa fields. The templates were also successfully checking the Matrix column values.

The Matrix field includes 3 Playa field types and 2 text. Have I just overloaded it?

Also - the site is in development. It's a friend's website and I'm not familiar with the web host. The site is running quite slowly, and there may be a problem with intermittent IP blocking. Could that kind of thing cause just one Channel field (the last field) to not respond?

1

OK - solved. I caused the problem myself by changing the type of a field that appeared earlier in the same group. I'd changed it from Rich Text to Wygwam. The corruption or whatever was easier to see when I worked in a different version of the browser. Field titles and descriptions of all fields after that field were showing in red, with an underlined rollover state.. Very weird.

As expected, changing that field type back to Rich Text wasn't enough... so I deleted and recreated it. My original Matrix field with Playa and other fields in the columns was just fine after that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.