2

Running EE 2.1.1 Wygwam 2.7.1 and Assets 2.1.3

In Wygwam modal settings, I select Assets as the File Browser and hit save.

Go into a Editor Configuration and the Upload Directory does not have a drop down, it just says no_upload_prefs

The file browser setting doesn't seem to do anything. If I add a directory to EE's file upload preferences, they show in the select list in the Editor Configuration, even though the file browser is set for Assets.

Anyone have an insight on this!!??

4
  • Mark, EE 2.1.1? You're almost certainly going to have to upgrade that to get this to work as expected.... – Lisa Jun 6 '13 at 18:16
  • @Lisa I'm having this same problem, but with EE 2.6.1, Wygwam 3.1.2, and Assets 2.1.4. – kmgdev Sep 13 '13 at 18:11
  • @Kristen - Is this on a public site, by chance? If so, could you shoot some CP/FTP creds over to support@pixelandtonic.com? – Brad Bell Sep 13 '13 at 18:46
  • If this has been resolved, posting the answer would be nice. I happen to have the same issue, months later. – epocsquadron Mar 14 '14 at 14:40
2

It turns out that you must have at least one upload location (for that site, if MSM is enabled) present in order to set the upload location in Wygwam.

For instance, I just performed a migration of Wygwam (2.7.1) data from using the native EE uploads to using Assets (2.2.2). Initially, I moved all of the images from the native upload location to an assets external location. Aterwards I deleted the old upload locations and set Wygwam to use Assets for the browsing.

I noticed this led to the same issue reported here. However, when I went back and created a new upload location (didn't matter where) I was able to get into the editor configurations and simply save them as is (such that the upload preferences had "--" selected). That made the browse button reappear in the wygwam image editor modal.

Unfortunately, you will need to keep at least one upload location on the local filesystem to keep the browse button working.

1
  • 1
    Fortunately, you can neglect to update indexes for the placeholder upload location, thus leaving it out of your Assets modal, while still having it present to allow for a browse button. – epocsquadron Mar 14 '14 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.