1

I seem to be having an issue where EE 1.6.8 doesn't seem to like the changes I'm making to the site.

For example. I've changed a category name from 'Contact / Careers' to 'Contact' but on the site it still shows 'Contact / Careers'. I've cleared browser & server cache, as well as EE cache and it's still doing this.

Looking in the DB shows the category is 'Contact' - So i'm a bit stumped as to where this name is still being pulled from.

Another weird thing... Is if I specify what categories to show using the category="2" tag, it shows 'Contact'!!!!!

What is going on?!

UPDATE:

{assign_variable:weblog="section"}

{embed="includes/head"}

{embed="includes/header"}

{exp:weblog:category_archive weblog="{weblog}" style="linear" show_empty="yes"}

    {categories}

        <h3><span><a href="#" title="{category_name}">{category_name}</a></span></h3>

        <div>

            <div class="tabs{category_id}">
                <ul class="subNav">
                    {exp:weblog:entries weblog="{weblog}" category="{category_id}" sort="asc"} 
                        <li><a href="#{url_title}" title="{title}">{title}</a></li>
                    {/exp:weblog:entries}
                </ul>

                {exp:weblog:entries weblog="{weblog}"  category="{category_id}"} 
                    <div id="{url_title}" class="col-container">

                        <div class="col2 left">
                            {section-left}
                        </div>

                        <div class="col2 right end">
                            {section-right}
                        </div>

                    </div>

                {/exp:weblog:entries}

            </div>

        </div>
    {/categories}

{/exp:weblog:category_archive}  

{embed="includes/footer"}
  • Show us the code! – Robson Sobral Jun 7 '13 at 10:55
  • Is it hard coded into the template? Was the category url title updated? – Siebird Jun 7 '13 at 16:28
  • @RobsonSobral Code added to the original question – Jason Mayo Jun 11 '13 at 9:32
  • @Siebird The Cat ID is pulled in dynamically... But the Cat Name it's pulling through, doesn't even exist in the database... But when I hard code in a Cat ID... It pull the correct one through that is in the database – Jason Mayo Jun 11 '13 at 9:33
  • Now contemplating that this is a parse order issue. Just saw you wrote that the category_id only works when you put it in manually versus dynamically. Have you contemplated using Stash to set the category ID and then instead of {category_id} within the channel entries loop, use the Stash get? Another option: embed templates for the channel:entries loop sections? – lealea Jun 13 '13 at 4:11
1
+150

Take a look here... make sure "Cache Dynamic Section Queries? " is set to "NO"

You can find this setting here in the CP: Admin › Section Administration › Global Section Preferences


It's also possible that your EE cache isn't clearing for some reason so I'd suggest FTPing to the server and manually clearing the cache directories.

| improve this answer | |
  • It looks like it wasn't clearing the cache! Deleting it through FTP solved this. Cache Dynamic Section Queries was already set to no. Thanks :) – Jason Mayo Jun 13 '13 at 13:04
  • Yeah! Sounds like the permissions on your cache directory aren't set correctly perhaps... Need help with that? – Anna_MediaGirl Jun 13 '13 at 16:19
  • It was set to 777, and it still couldn't delete it - which was weird! Thanks for your help :) – Jason Mayo Jun 14 '13 at 9:09
  • Weird. Maybe delete and recreate the directory? – Anna_MediaGirl Jun 14 '13 at 22:29
0

Jason - Have a look at any .htaccess within the path of your install. This could be re-writting the urls...

| improve this answer | |
0

Make sure that the Category Name/Category URL Title has no duplicate. For example, if you have the same category name in two different category groups, that might freak it out perhaps?

e.g. if you have a recipe website, say you have a Category Group called Lunch and another called Dinner. Both could have categories called "Soup."

| improve this answer | |
  • There is only one category group, and the category got removed then added back in so theres none with duplicate titles or url titles :( – Jason Mayo Jun 11 '13 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.