3

I want to show the date format in european style (dd-mm-yyyy). I changed and configured all settings to European. $config['default_site_timezone'] = Europe/Amsterdam doesn't solve the problem. Can anyone help me with this? I am running on EE 2.6.1.

  • I could do with this too! – foamcow Jun 12 '13 at 9:08
3

I posted this as a bug report to Ellis Lab and followed it up with this comment.

I think there is a misunderstanding on the meaning of “European” format.

By default the dates are shown as mm/dd/yy - which is a US centric format. Switching to “European” changes the format to yyyy-mm-dd - this is certainly more european but is actually ISO 8601 format

I think the expectation was for “European” to be simply dd/mm/yy (or dd-mm-yyyy).

The same basic idea as the US format but showing the day before the month.

UPDATE

You can set a custom date format for entry listings in the CP by using Zenbu

| improve this answer | |
  • Ok, can you post the reaction from Ellislab once they replied? – Ibe Garritsen Jun 12 '13 at 11:06
  • I doubt anything will be done. It's not really a bug just a misinterpretation. Technically the date format that is used when you set "European" IS European. It's just not the one you want. I guess you will need to alter the core. This is something I need to do but won't be looking at it for a couple of weeks. – foamcow Jun 12 '13 at 11:18
  • I've had feedback from Ellis Labs and they agree with me that "European" isn't what that format is. They say they will be looking at the matter and actually discussed it recently anyway and are keeping it on the Bug list. I have suggested they allow the specification of a custom format. – foamcow Jun 12 '13 at 21:31
2

If it's on the front-end then you can use date variable formatting to output it however you want. To output the dd-mm-yy format you'd just use:

{current_time format="%d %m %Y"}

The full reference can be found here with some data formatting constants included too.

EDIT

For the Control panel go to Admin > Localisation settings and set Server Timezone to your country and Default Time Formatting to European. In additon to this also make sure you go to your Member > My Account > Localization Settings and set this to European too.

That should see the date formatting change to a European format for your account as well as new accounts.

| improve this answer | |
  • The title says "in Control Panel", so I doubt setting the date format in the front-end is the solution he's looking for... – janvl Jun 12 '13 at 9:10
  • It is not on the front-end but on the backend, a client logs in the backend and maintains the site. – Ibe Garritsen Jun 12 '13 at 9:25
  • @janvl My mistake. I simply missed that part. The time spent on the negative comment could have been more wisely spent on providing a positive solution. It's a Q&A forum so focus on providing the answers. – Ian Jun 12 '13 at 9:43
  • Your suggestion to set the localisation settings should work but doesn't appear to make any difference in 2.5.5. Could somebody confirm as to whether this is the case? I've just tried it and I'm still getting the 'standard' US formatting. – foamcow Jun 12 '13 at 10:01
  • Same problem with 2.6.1. I've tried all possible settings... – Ibe Garritsen Jun 12 '13 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.