1

I recently upgraded a client site from 2.5.5 to 2.6.1 and upgraded Freeform to version 4.0.12 in the process the Captcha on all the freeform contact forms generates an error even after careful entry:

You must submit the word that appears in the image

I contacted Solspace and they could not replicate the problem or help me fix it, so I am looking for something I may have overlooked.

Here is the code I am using:

<p>For security, please enter in the word you see.</p>
<p>{freeform:captcha}</p>
<p><input style="border-color:#ccc;" type="text" name="captcha" size="18" class="text_input" /></p>

I checked the path to the Captcha images and the folder permissions are set to 777. It is required of logged in members.

Is there anything else I may have overlooked in this?

Thanks!

P.S. Here is the link to the Solspace forum on this topic: http://www.solspace.com/forums/viewthread/17083/. It is marked as resolved, but the problem still exists. They just ran out of ideas.

  • Do you have caching turned on in the particular template in question? – Justin Long Jun 14 '13 at 2:14
1

Did you update Freeform to latest version aswell? Current is 4.0.12.

  • Yes, this is current. – fmz Jun 13 '13 at 15:42
1

I found this problem with composer created forms with "Require CAPTCHA with logged-in members?" set to "No". When I attempt to fill in the form when logged in creates this error. EE 2.7.3 Freeform Pro 4.1.3

0

perhaps over your allowed diskspace on the account?

we had this with a site recently and it turned out the automated backups were maxing out the server space and caused the generated captcha not to work.

  • Hi Steven, the account has unlimited disk space, so in this case that would not apply. Thanks for the idea though. – fmz Jun 13 '13 at 15:48
  • are the permissions set for the right user? – Steven Grant Jun 13 '13 at 16:22
  • The captcha folder is set to 777. – fmz Jun 14 '13 at 22:04
0

Can you share the Solspace forum link where you asked them the question, so we can see what steps have already been taken?

Can you update your original post with the Freefom version you're using.

  • Added link to Solspace Forum – fmz Jun 18 '13 at 12:58
0

It looks like this was addressed in version 4.1.4 update. See: http://www.solspace.com/docs/freeform/change_log/#v4.1.4

"Updated documentation regarding 'require_captcha' parameter and logged in members. Freeform cannot override the EE 'Require Member Captcha' preference when set to 'No'."

... and ...

"Fixed a bug where Captcha was being required for logged in members even with the EE 'Require Member Captcha' preference set to 'No'."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.