0

I'm trying to search inside 'Matrix' cols with Simple Search module - but it's just not happening.

I've ensured that the field is 'Searchable' and that all columns in the Matrix are 'Searchable' also. The entries themselves are not closed & not in the future - but they still won't show up in the search results.

This is the code I have for the Simple Search form:

{exp:search:simple_form result_page="search/results" no_result_page="search/no-results" results="10" channel="shop_product" where="all" search_in="everywhere"}
        <ul>
            <li><input type="text" name="keywords" /></li>
            <li class="submit-btn"><input type="image" src="{site_url}assets/images/icon-search.png" width="32" height="32" name="search"/></li>
        </ul>
{/exp:search:simple_form}

Any ideas why this wouldn't work?

0

If you've enabled the searchable columns for the Matrix field while there were existing entries, you'll have to save each of those entries in order to make it work. Basically, the searchable content needs to be put in the exp_channel_data table, which Matrix does upon saving entries.

| improve this answer | |
  • Ouch. Okay, is there a way to save all entries in to exp_channel_data? The site has over 500 entries... Bit too much opening each one and saving it again. – Jason Mayo Jun 14 '13 at 13:06
  • There might be a script/query available somewhere. Better ask P&T. – Low Jun 14 '13 at 13:36
  • There is indeed a script: expressionengine.stackexchange.com/questions/3510/… – Derek Hogue Jun 14 '13 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.