0

This is a strange one, so I'll have to give a little history.

To allow ad-hoc image galleries to be placed within the body content of pages on the site I'm using a matrix that holds "galleries" while using an Assets field set to "multiple" for the images in each gallery. A CopeePastee field is used to allow the content editor to easily copy the {gallery_x} tag so they can place it wherever they need to within the main body content field.

The templates use the template partials technique. My view-model template renders the gallery content into the gallery_{row_count} stash variables with the type="snippet" parameter. On the view template, I use parse_vars="yes" to render those galleries within the body content.

This has been working fine since launch. Today I noticed a live page that had {gallery_1}, {gallery_2} tags, etc displayed as a tag instead of rendered.

I immediately thought something was wrong with the Cache so I flushed the cache entry for this specific page. When logged into the CP, the templates do not run through CE Cache and this page rendered fine, although slow due to the 185 queries required to render this many (7) galleries.

I hit the page via a Chrome Incognito browsing session and the galleries display as expected. When I hit refresh to get the newly cached version (and to check speed) it's back to showing the unrendered gallery_x tags.

Memory utilization for this page is under half of what's available.

Other pages in the site that also use this identical template and identical gallery feature work fine as well. With CE Cache disabled, it renders fine too.

Any ideas?

Gists

Example URLs:

Versions

  • EE: 2.5.3
  • CE Cache: 1.9.5
  • Matrix: 2.5.5
  • Assets: 2.0.4
  • Stash: 2.3.9 beta
1

It turns out the non-rendering tags were actually within a different field... something other than the body text field that had the parse_vars="yes" parameter set. Something apparently changed in a recent version of Stash or CE Cache that caused those tags to no longer be processed. I'm not sure why it was working before but it was.

Adding the parse_vars="yes" to the other field solved this specific issue.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.