I have three sites that I'm adding CAPTCHAs to (www.hoekstratruck.com/index.php/contact, www.hoekstratransportation.com/index.php/contact, and www.hoekstraspecialty.com/index.php/contact/ctest). On the first two, the captcha works fine. It shows up and says that it is required to submit the form. On the third site, however, when I include the {if captcha} tag, nothing shows up. If I leave that tag out, just having

<p>Please enter the word you see in the image below:<br/> {captcha}<br /> <input type="text" name="captcha" value="" size="20" maxlength="20" style="width:140px;" /></p>

it displays the prompt and the text box, but not the image (and it doesn't print "{captcha}" either). I have double checked that the server path and image html path are both correct.

All three sites are running off EE v1.7.1 and I don't see any difference in how the first two sites are set up compared to the third site.

Please help!

1 Answer 1


This has bitten me a few times and it has always been a path issue. Double check your captcha preferences.

Also, make sure the captcha directory/folder is writable by your webserver

  • I have double (and triple) checked the paths, and they seem to be correct. When I enter the full URL to the CAPTCHA folder and add the name of one of the images, for example hoekstraspecialty.com/images/captchas/1371664869.85.jpg, I can see it in the browser. The folder itself has file permission 777, while the images are set to 644. This is the same as on the other two sites I listed in my initial post. Jun 20, 2013 at 18:11
  • I now have the captcha on one form working while the other doesn't work. The only difference is that the second one is in a table while the first isn't. Any ideas? Jun 20, 2013 at 19:40
  • Both captchas are now working, though one of them is not in the '{if captcha} {/if}' tags. No idea what made them suddenly appear. Jun 20, 2013 at 20:12
  • I wish I could help more but I am trying to remember what else would cause them to not show up... especially if you are using the same code with correct settings across all the site. Jun 20, 2013 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.