1

Have been looking through the previous solutions in here but still not able to make this work. I am able to display the normal data ok however not the Playa data, it is blank. Any help would be great if possible.

{exp:channel:entries channel="statistics" dynamic="off" limit="1" url_title="{segment_3}"}
    {title} {!-- Page title --}

    {exp:channel:entries channel="statistics"}

        {stats_driver_points_table} 

            {stats_driver} {!-- Matrix field name with playa inside --}
                {title}  {!-- Playa title, display blank --}
            {/stats_driver}
            {stats_r1_q}  {!-- Displays ok --}
            {stats_r1_q}  {!-- Displays ok --}
            {stats_season_total}  {!-- Displays ok --}

        {/stats_driver_points_table}

    {/exp:channel:entries}

{/exp:channel:entries}
1

So I have this working now.. turned out that removing it from the embed did the trick

{exp:channel:entries channel="statistics" dynamic="no" limit="1" url_title="{segment_3}"}
{title}
{/exp:channel:entries}

{exp:channel:entries 
        channel="statistics"
        dynamic="no"
    }

{stats_driver_points_table}

    {stats_position}
    
    {stats_driver}
    {driver_fullname}
    {/stats_driver}
    
    {stats_r1_q}
    {stats_r1_c}
    {stats_r2_q}
    {stats_r2_c}
    {stats_season_total}

{/stats_driver_points_table}

{/exp:channel:entries}

One last thing is that now only "open" entries will display in the playa field, how can I display closed too, if it's possible?

| improve this answer | |
  • {stats_driver status="open|closed"} {driver_fullname} {/stats_driver} – Tom Mills Jun 26 '13 at 11:48
0

I'm guessing your inner channel entries tag is an embed? I made a couple of changes to your example that may help. Also, try adding prefixes to the matrix field and the playa cell:

{exp:channel:entries 
    channel="statistics" 
    dynamic="no" 
    limit="1" 
    url_title="{segment_3}"
}
    {title}

    {!-- EMBED --}
    {exp:channel:entries 
        channel="statistics"
        dynamic="no"
    }

        {stats_driver_points_table var_prefix="mx"} {!-- Matrix field --}

            {mx:stats_driver var_prefix="pl"} {!-- Playa column --}
                {pl:title}
            {/mx:stats_driver}

            {mx:stats_r1_q}
            {mx:stats_r1_q}
            {mx:stats_season_total}
        {/stats_driver_points_table}

    {/exp:channel:entries}
    {!-- END EMBED --}

{/exp:channel:entries}
| improve this answer | |
  • Yes it's an embed. Have tried the above change but no success. I also attempted just to drop in some text before {pl:title} and this doesn't show either, would this be a clue or is that just not going to happen? <pre> {mx:stats_driver var_prefix="pl"} {!-- Playa column --} Driver name:{pl:driver_fullname} {/mx:stats_driver} </pre> – Tom Mills Jun 24 '13 at 17:52
  • If there are no results on the playa field then it would make sense that other text wouldn't display. It could be a status issue on the related entries (the ones with driver_fullname field), what are those set at? – Romans-8---31-39 Jun 24 '13 at 18:26
  • thanks for reply. i did have it with some open and some closed, so changed to all open but still no display. The playa fields are displaying in the admin within the entry etc.. just not pulling out into the front end.. making me a little crazy ;-) – Tom Mills Jun 24 '13 at 18:44
  • Are you sure stats_driver is the correct matrix cell name where your playa related field is? I'd start looking at all the little things, because it seems like it should be working. – Romans-8---31-39 Jun 24 '13 at 19:06
  • yes seems to be, see screen shot here link – Tom Mills Jun 24 '13 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.