0

I've got 2 channels, "message" and "message series" and I'm using a relationship field in the message channel to tie a sermon to a sermon series. My template group is called media, and there is a media-view template that I'm trying to use to display a listing of all the sermons in a particular sermon series. My issue is that when I click one of the sermon series to view the sermons in that particular series, it goes to a blank page with my header and footer on it, but no content. It's trying to go to media/media-view/name-of-sermon-series. However, when I view the rendered template from the EE control panel, it displays correctly at media/media-view. That would be fine except, if I change my link to go to media/media-view, and click the link to a sermon series, it always takes me to the same sermon series page, regardless of which link I'm clicking. Something in my code is off, and I can't for the life of me figure out what it is. Any help would be greatly appreciated.

here's my code from my media template:

{embed="embeds/html_header" page_title="Media"}
{exp:channel:entries channel="message_series" orderby="date" sort="asc" limit="10" paginate="bottom" {gv_param_disable_default}}    

        <li class="section-post">
            <a class="message-link" href="{path=media/media-view/{url_title}}"><img src="{series_image}" class="message-image" title="{title}" alt="{title}">
            <span class="mask">
                <img src="{site_url}/images/interface/ico-search.png">
            </span>
            </a>
            <a href="{path=media/media-view/{url_title}}"><h2 class="inline-header">{title}</a></h2><br />
            <p><i>{series_begin_date format='%Y'}{if series_association != ""}, Series{/if} </i></p>

        </li>
{/exp:channel:entries}

and here's my code from my media/media-view template:

{embed="embeds/html_header" page_title="{exp:channel:entries channel="message"}{title}                {/exp:channel:entries}"}
{exp:channel:entries channel="message" limit="1" {gv_param_disable_default}}


                    {series_association}
                    <h1 class="section-header">{series_association:title}</h2>
                    {snp_social_share}
                    <div class="section-post">
                    <p>{series_association:series_summary}</p>
                    <img src="{series_association:series_image}" class="drop-shadow message-image" title="{series_association:title}" alt="{series_association:title}">
                    <br /><br />
                    {/series_association}   
            {/exp:channel:entries}      
                <ul>
            {exp:channel:entries channel="message" orderby="date" sort="asc" {gv_param_disable_default}}
                    <li class="media-view">
                        <h2><u>{title}</u> - <i><h5>{message_date format='%F %d %Y'}</h5></i></h2> 
                        <p>{if message_speaker}<i>Speaker:</i> {message_speaker}{/if}
                        <p>{if message_scripture}<i>Scripture Reference:</i> {message_scripture}{/if}
                        <p>{message_summary}</p>
                        <audio src="{message_audio}" preload="none" />
                        <h5>{message_date format="%F %j, %Y"}</h5>
                    <li>
                    <br />
            {/exp:channel:entries}
                </ul>
1

I would try changing the message tag to the following:

{exp:channel:entries channel="message" limit="1" dynamic="no" url_title="{segment_3}" {gv_param_disable_default}}

This should disable any "guessing" EE might be doing and force it to match the entry you're actually requesting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.