2

I'm running EE 2.6.1. I have setup a form using Freeform 3.5 but it wasn't sending notifications. I went through the Solspace troubleshooting guide and double-checked everything there. I found this thread and tried everything recommended there, to no avail. Here's where I am at this point...

I have already been using Mandrill to get around clients' server settings, so I did that from the get go on this site. However, when the Freeform form wouldn't send I tried a test from the Communicate tool. With SMTP set and using my Mandrill credentials, I get these errors:

A PHP Error was encountered Severity: Warning Message: fsockopen() [function.fsockopen]: unable to connect to smtp.mandrillapp.com:587 (Connection timed out) Filename: libraries/Email.php Line Number: 1884

A PHP Error was encountered Severity: Warning Message: Cannot modify header information - headers already sent by (output started at /home/closeit/public_html/dashboard/codeigniter/system/core/Exceptions.php:170) Filename: core/Common.php Line Number: 408

An Error Was Encountered Unable to send email at this time. The following SMTP error was encountered: 110 Connection timed out Unable to send email using PHP SMTP. Your server might not be configured to send mail using this method.

So I've tried switching the mail protocol to both PHP Mail and Sendmail. And although I receive the "Your email has been sent" notification, I never receive the email.

1

Some hosts don't support sending emails using SMTP, which is likely the reason you are getting that fsocket error. For this reason Mandrill and other API services recommend using their API which uses HTTP (vs SMTP).

Postmaster is a robust utility for using various email API services. You could use Postmaster to send all system emails with HTTP using Mandrill. Postmaster has a hooks API, so it could be used to send emails from Freeform directly, but that would require some PHP the first time around. So if the default system email override doesn't work, a deeper level of integration is just a few lines of code away.

While this doesn't exactly fix your problem exactly, it is an alternative solution to solve a bigger problem. https://objectivehtml.com/postmaster

  • Thanks for the reply, @justin. I have submitted a support ticket to the host to see if they don't support SMTP. – pedalGeoff Jul 2 '13 at 20:11
  • most likely they only support smtp from their own email server - not from an external one - and even then the email from address must match. i know thats the case with many of them. – lukemh Mar 19 '15 at 7:51
0

No idea whether this is related to poster's case, but I had same problem on AWS EC2 server.

The solution was to enable 'default' security group for the server instance in AWS management console.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.