0

On the root there is an EE install with a .htaccess to remove the index.php Now there is a new installation in the www.root.be/test/newEE

in the newEE there is a new EE installation for testing

But because of the htacess of the root, whatever url's i type they keep redirecting to something totally different than the goal or how standard EE should be.

for example i have a template called "home" with a page in it called "form" Trying to find a way to correctly put the url and view the page but that is not working out i tried several options www.site.com/test/newEE/{template name}/{specific page} www.site.com/test/newEE/index.php/{template name}/{specific page} www.site.com/test/newEE/{specific page}

but nothing seems to work how can i fix this please?

this is the htacess:

# Enable Rewrite Engine
#—————————————————————————————————————
RewriteEngine On

RewriteBase /

# Redirect index.php Requests
#—————————————————————————————————————
RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC]
RewriteCond %{THE_REQUEST} !/system/.*
RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,L]

# Standard ExpressionEngine Rewrite
#—————————————————————————————————————
RewriteCond $1 !\.(css|js|gif|jpe?g|png) [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php/$1 [L]



# Redirect to www 
#—————————————————————————————————————
RewriteCond %{HTTP_HOST} ^siteurl.be [NC]
RewriteRule ^(.*)$ http://www.siteurl.be/$1 [L,R=301]

AddType font/ttf .ttf
AddType font/eot .eot
AddType font/otf .otf
AddType font/woff .woff

AddType audio/mp3 .mp3 
AddType video/ogg .ogv
AddType video/mp4 .mp4
AddType video/webm .webm
SetEnvIfNoCase Request_URI \.(og[gv]|mp4|m4v|webm)$ no-gzip dont-vary


<FilesMatch "\.(ttf|otf|woff)$">
    <IfModule mod_headers.c>
        Header set Access-Control-Allow-Origin "*"
    </IfModule>
</FilesMatch> 

<IfModule mod_expires.c>
    ExpiresActive on

    ExpiresDefault                          "access plus 1 month"
    ExpiresByType text/css                  "access plus 2 months"
    ExpiresByType application/javascript    "access plus 2 months"
    ExpiresByType text/javascript           "access plus 2 months"

    <IfModule mod_headers.c>
        Header append Cache-Control "public"
    </IfModule>

</IfModule>
1

You really need to take the second installation out and place it on a subdomain. test.root.be for instance. Then it can operate completely independently and wont clash with your existing install. What you're effectively doing there is running EE within EE as far as the URL schema is concerned.

| improve this answer | |
  • Thanks for the input but subdomain is not an option here – Visual Jul 2 '13 at 12:21
  • Then I'd recommend another domain. Putting two inside the same ecosphere is always going to cause problems with routing and default handling. If you did have no other alternative however then try using Freebie. You should be able to define a 'breaking segment' which in this case would be newEE. After which the first EE install will ignore all segments afterwards and not try to process them. You will have to ensure you second installation has correct paths to the subdirectory too. – Ian Jul 2 '13 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.