1

Running ExpressionEngine V2.6.1 (20130506) and Assets 2.1.3 and whenever I upload images to Assets or have some already uploaded and try to view them either in Assets or WygWam (which I'm also using on a site) then there are no thumbnails shown for any images at all.

I have checked on the server and in the _thumbs folder there are actually images in there which are small however these images have permissions of 666 and Owner & Group = apache where all other files that I have uploaded have Owner = sitename & Group = psacIn (not sure if it is an I or a lowercase l as my FTP editor won't allow me to copy that text).

Just wondering if the Owner & Group is the culprit here or is there something else I should be looking into?

Thanks,

Mark

1

Assets stores it's thumbnails in the /cache folder. If you had previously uploaded images in the upload directories, did you run the "Update indexes" function? http://docs.pixelandtonic.com/assets/using/indexing.html

That should get your thumbs back.

| improve this answer | |
  • Yep ran the update indexes function and still no thumbs :-( I also noticed that if I downloaded the thumbnails that it created to my hard drive and then re-upload them to the thumbs folder then the owner and group are as my owner and group but as soon as I run the update indexes function then they are changed to apache for both. Both ways don't work though either uploading them myself or their being created by the server. – Mark Bowen Jul 2 '13 at 17:37
  • Just noticed also that if I view the source in the Assets module that I get assets-thumb div with nothing in it but below that are list items with a data-file-url which has the link in it to the image so Assets is spitting out some of the information but just nothing into the assets-thumb div :-( – Mark Bowen Jul 2 '13 at 17:42
1

sorry to hear you're having troubles!

The thumbnails for Assets are not being stored in the _thumbs folder - that's for EE's Filemanager. Since Assets serves thumbnails in different sizes, we're storing it in system/expressionengine/cache/assets folder. Can you make sure that the system/expressionengine/cache folder is writable?

If it is, then please do shoot us an email to support@pixelandtonic.com so we can track this down and fix it for you.

| improve this answer | |
  • Hi Andris. Yes the system (different name on this system now)/expressionengine/cache folder is writable. I did however have to create the assets folder inside the cache folder myself as it never got created. I will send an email to you now, thanks. – Mark Bowen Jul 3 '13 at 8:27
  • Hi Andris, Was just going to send an email and went into the admin panel and everything is now working!!! Seems the host was updating the PHP version on the server and whilst that was happening all sorts of problems were happening. Now that the PHP version is up to date everything is okay. I wasn't aware of this being done though until just now so sorry about that. Please consider this sorted now. Hopefully nothing else will crop up now. Thanks, Mark – Mark Bowen Jul 3 '13 at 8:32
  • PLEASE IGNORE - Why as soon as posting do I figure out how to do something. Control clicking on the folder on the left side of Assets does it. I was trying inside the folder where the listings were being shown :-) Hi Andris, On a slightly related note is it possible to create folders via Assets inside an upload location? – Mark Bowen Jul 3 '13 at 9:41
  • Mark, you can also right-click which has the same effect as ctrl+click :) – Andris Sevcenko Jul 3 '13 at 11:11
  • 1
    Not on an older Mac you can't ;-) – Mark Bowen Jul 10 '13 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.