I am trying to add rackspace cloud files to assets, but when saving I get white screen. Any ideas why?

EE 2.5.5 Assets 2.1.3

I have tried with amazon s3 , and private and public repos on both to test.

  • Does the save complete? Does the file still get sent to Rackspace or does it just hang? Also have you double checked your access credentials and made sure that you've indexed before trying to upload?
    – Ian Young
    Commented Jul 3, 2013 at 9:00
  • Have you turned the debug on? Admin > Output & Debugging > Debug Preference Commented Jul 3, 2013 at 9:02
  • Oliver - saving what exactly do you get a white screen? Commented Jul 3, 2013 at 11:10
  • The save does not complete, I enter all the details that all seem correct, it finds the correct bucket etc but when clicking save (to save the external source as a folder to upload to) I get the white screen
    – Oliver Ker
    Commented Jul 4, 2013 at 8:04
  • Turned on debugging and get this error Fatal error: Call to undefined method stdClass::result_array() in /path/to/server/system/codeigniter/system/libraries/Javascript.php on line 765
    – Oliver Ker
    Commented Jul 4, 2013 at 8:28

1 Answer 1


Try uploading using the native File module and verify that the directory is in fact writable by EE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.