0

I've tried the Solspace User module registration form and the standard EE registration form and I'm get the same error on both submissions:

The form you submitted contained the following errors: You must provide a valid registration code to complete your registration. (note: Registration codes, like passwords, are case-sensitive.)

I have no reference to registration codes or even a captcha in my registration forms. In my member preferences I have allow member registrations set to yes, require terms of service is no, enable membership captcha is no.

I'm not sure what is wrong and what registration code EE is looking for?

Any help would be very much appreciated.

Julie

1

Could it be anything to do with the User Key?

http://www.solspace.com/docs/user/key/

I haven't used them before but it rang a bell...

  • I don't have a user key set up though. And my form code doesn't reference to a user key. Plus this error is occurring even on the standard EE registration form. So I'm not sure it's a Solspace User specific problem. – Julie Alchin Jul 3 '13 at 11:23
  • Sorry - I missed that it was also EE specific. Couple of things, does the error still occur when you uninstall User (backup the DB first of course). Also, can you list out what other addons you have installed? – Dave O'Brien Jul 3 '13 at 11:59
  • Yes still occurs when User is uninstalled. I've got quite a few other add ons: Backup Pro, Channel, Comment, DataGrab, Disqus, EE Donations, Email, Emticon, File, Forms, Freeform Pro, jQuery, Mailing List, Member, Membrr, moreEvents, MX Google Map, NSM Live Look, Pages, Query, REElocate, Rich Text Editor, RSS, SafeCracker, Search, Stand-alone member edit, Statistics, User, Wygwam – Julie Alchin Jul 3 '13 at 12:57
  • I'm pretty sure it's not a standard EE error, I've never come across it before which is why I'm thinking it's got to be an third party addon. The only addons that look like they'd do that are devot-ee.com/add-ons/invitations and devot-ee.com/add-ons/registration-codes. This might be me telling you how to suck eggs, but did you check your extensions page to see what you've got installed there? – Dave O'Brien Jul 3 '13 at 13:05
  • How embarrassing. I had the extension RogEE Registration Codes enabled, which we used a while a go but no longer need. Totally forgot about it. It all works fine now that I've disabled that. Thanks for your help :) – Julie Alchin Jul 3 '13 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.