I have a set of templates in my default template group called "home".
These templates are "about", "contact-us", "membership" and of course "index".

Only the "index" template will display without the name of the group in the url.
PASS: example.com/
PASS: example.com/home/about
FAIL: (404) example.com/about
PASS: example.com/membership
FAIL: (404) example.com/home/membership

I have tested this with and without an "index.php" .htaccess re-write. No luck.

(Details: Brand new EE 2.6.1 install on stable cPanel server.)

I've never seen this happen before.
Thanks.

up vote 5 down vote accepted

This is as a result of the Strict URLs feature being enabled by default in EE2.6+ (previously it was opt-in, now it's opt-out).

If you want the old behaviour back you can change it in Global Template Preferences

  • I just came across the exact same issue. Thanks foe the answer! – Jim Pannell Oct 7 '13 at 10:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.