3

We've just launched our EE2 based website and are now experiencing an odd problem:
In the control-panel it is no longer possible to save any changes to the sites content entries (or create new ones). When pressing 'Submit' or 'Save Revision' the edit-form is displayed again (containing the changed content).

Everything else on the site and control-panel work as expected, including changing settings and templates.

I activated all possible debug mechanisms (EE-Log, Debug Preference:1 (I am Super Admin), apache-log, Output-Profiler & Template-Debugging), but nothing shows up.
The SQL-Trace doesn't even contain an update statement for the channel tables and I manually tested, that the application user is permitted to access/update those tables.
I've also tried changing the "Process form data in Secure Mode" and "Deny Duplicate Data" optional without noticeable effect.

Any ideas where to look for the problem or any other options to try?

Thank you!

Best Regards,

Jan

1
  • We're having the exact same problem at my work. Any updates here? – Ben Racicot Nov 22 '13 at 21:14
3

Have you customised the publish layout at all? If you have a hidden field that is required, it won't allow you to save, and obviously won't be visible so you can see that it's required! Ensure that all fields are visible and when it returns to the edit screen (without saving), check all the tabs and all fields to ensure there's none highlighted as being required.

Then try entering values into all fields to see if that allows for saving.

If still no joy, disable extensions (not individually, just the global disable in top right of Extensions page) and try again (there may be PHP errors, but at least it may narrow it down).

Finally, try creating a new channel (default options) with no custom fields - can that be saved? If so, try adding the same field group to this new test channel and see if the problem re-occures. If it does re-occur, you know there's a problem with a field type preventing saving, if it saves without problem, you know there's a problem with the channel settings.

Update - try these suggestions: Unable to publish new channel entry

3
  • I checked in the database: we don't have any hidden fields. I could create a new channel, but not safe content for it. (I cannot easily disable all extensions right now, so I have to check this later) – Jan Jul 12 '13 at 11:28
  • Added link to suggestions on similar thread – Peter Lewis Jul 12 '13 at 12:13
  • Thanks for the suggestions. Indeed I have set up the root_url in the same way (to "/"). Unfortunately I can't easily change it in our setup. – Jan Jul 15 '13 at 11:40
0

Jan, can you check other tab of entry edit form like Options and Date. Basically "Options" tab and see if correct Author is selected.

6
  • The Author is the original one, but changing it to account had no effect. Also only changing stuff like the date or status didn't work. – Jan Jul 12 '13 at 9:49
  • Can you check if it's happening for all the channel entries or for only one channel only... – Bhashkar Yadav Jul 12 '13 at 11:44
  • I haven't checked all, but for now I haven't found one that is working. – Jan Jul 12 '13 at 14:50
  • You should use EP Mega Error (devot-ee.com/add-ons/ep-mega-error) as Peter suggested in his answer. – Bhashkar Yadav Jul 12 '13 at 17:10
  • EP Mega Error also doesn't show anything. – Jan Jul 15 '13 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.