1

Migrated to a new server and my server path has changed.

I changed the path in all the file upload preferences etc. but Pixel and Tonic Assets seems to want to hold on to the original path.

If I look at the database in MySQL, the old paths are there. When I go to Assets and hit "Update" indexes", nothing happens and the button gets greyed out. When I go to the Assets file manager there are no files. Just the spinning icon to the right.

So I figured I would just change the paths in the config.php file as such:

$config['upload_preferences'] = array(

        6 => array(                                                            // ID of upload destination
            'name'        => 'Homepage Images',                          // Display name in control panel
            'server_path' => '/home/content/02/xxxxxxxxx/html/images/uploads/homepage/', // Server path to upload directory
            'url'         => 'http://www.xxxxxxxxx.com/images/uploads/homepage/'      // URL of upload directory
        ),
        5 => array(                                                            // ID of upload destination
            'name'        => 'Images',                          // Display name in control panel
            'server_path' => '/home/content/02/xxxxxxxxx/html/images/', // Server path to upload directory
            'url'         => 'http://www.xxxxxxxxxxxxx.com/images/'      // URL of upload directory
        )
    );

But that does not seem to help either. There are a lot of files. Do I just need to leave it on the Assets file manager page and wait for the spinning icon to stop?

  • Hey, this sounds like a case worthy an email to support@pixelandtonic.com. Be sure to reference this thread and, if possible, include CP access for a speedier resolution. – Andris Sevcenko Jul 15 '13 at 18:54
3

Thanks to the great people at PixelandTonic I have this resolved.

I was having session issues with another plugin earlier and the solution to this was to change the session preferences in the control panel from "Sessions IDs only" to "Cookies only". As usual, fixing one thing will break three. The response from P&T:

In your security and session preferences, CP Session type was set to "cookies only" and User session type was set to "session ID only".

Assets makes a lot of Ajax requests and due to the nature of EE, they can only be made via frontend, so User session is used there to determine the access privileges, and when making those requests, Assets could not determine that the user was a valid CP user, so it denied every request as a security precaution.

I set them both to use Cookies only and now it all works fine. Another workable scenarion is Admin: Session And Cookies, User: Cookies.

This actually fixed a couple of other unrelated issues I was having in the control panel.

In conclusion, the issue was not due to the migration, it was always there. Just an annoyance to fix later. The migration just brought the issue to depth con 5.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.