1

I'm migrating a site from Media Temple (GS) to (DV), but every URL without index.php returns the homepage. URLs with index.php display correctly.

FastCGI is disabled, here are the contents of my .htaccess file:

AuthUserFile /path/to/my/password.file
AuthName "Please Log In"
AuthType Basic

require valid-user

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond $1 !\.(gif|jpe?g|png)$ [NC]
    RewriteRule ^(.*)$ /index.php?/$1 [L]
</IfModule>

EE 2.6.1

2 Answers 2

1

normally I've found this to be the URI_PROTOCOL config setting.

Go through the range of options in config.php and you should be good.

0

Unless your server requires the ? to make anything that follows index.php a querystring, it's probably not necessary in your RewriteRule and could lead to the behavior you're describing.

RewriteRule ^(.*)$ /index.php?/$1 [L]

becomes:

RewriteRule ^(.*)$ /index.php/$1 [L]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.