1

I am using this Master Config, http://eeinsider.com/articles/multi-server-setup-for-ee-2

Problem is my site now shows a server error.

Here is a pastie of my master config file.

http://pastebin.com/G2PvFFck

ERROR

Warning:
require(/Applications/MAMP/Development/ExpressionEngine/pixelsandcode/../config/‌​config.master.php):
failed to open stream:
No such file or directory in 
/Applications/MAMP/Development/ExpressionEngine/pixelsandcode/pixels/expressione‌​ngine/config/config.php
on line 38

Fatal error:
require():
Failed opening required '/Applications/MAMP/Development/ExpressionEngine/pixelsandcode/../config/config.‌​master.php'
(include_path='.:/Applications/MAMP/bin/php/php5.4.10/lib/php') in
/Applications/MAMP/Development/ExpressionEngine/pixelsandcode/pixels/expressione‌​ngine/config/config.php
on line 38
14
  • Whats the server error? anything in logs? also in index.php set debug to "1" to show errors Jul 17 '13 at 13:38
  • Also this is my config.php file which sits in: /pixels/expressionengine/config/ pastebin.com/Us212bzE
    – Nick Toye
    Jul 17 '13 at 13:39
  • It just says Server Error, in Chrome. Apache logs just say: [Wed Jul 17 14:41:39 2013] [error] [client 127.0.0.1] File does not exist: /Applications/MAMP/Development/ExpressionEngine/pixelsandcode/favicon.ico In Firefox I just get a white screen.
    – Nick Toye
    Jul 17 '13 at 13:42
  • Okay with the white screen you need to edit the index.php in the webroot and set debug= "1". Expression engine hides errors by default and you need to enable debugging. Once you do that post your errors Jul 17 '13 at 13:45
  • Warning: require(/Applications/MAMP/Development/ExpressionEngine/pixelsandcode/../config/config.master.php): failed to open stream: No such file or directory in /Applications/MAMP/Development/ExpressionEngine/pixelsandcode/pixels/expressionengine/config/config.php on line 38 Fatal error: require(): Failed opening required '/Applications/MAMP/Development/ExpressionEngine/pixelsandcode/../config/config.master.php' (include_path='.:/Applications/MAMP/bin/php/php5.4.10/lib/php') in /Applications/MAMP/Development/ExpressionEngine/pixelsandcode/pixels/expressionengine/config/config.php on line 38
    – Nick Toye
    Jul 17 '13 at 13:47
1

If you see this or a similar error with the double-period in the path -- /../config/config.master.php -- you just need to modify the following in config.master.php

REPLACE ANY OCCURRENCE OF THIS

require $_SERVER['DOCUMENT_ROOT'] . '/../config/config.' . ENV . '.php';

WITH THIS

require $_SERVER['DOCUMENT_ROOT'] . '/config/config.' . ENV . '.php';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.