3

I've had a look through all the answers on here (this one seems the most complete) but since I'm using EE v 1.6.0 in this case I'm unsure what to follow.

I downloaded my site to run locally using MAMP, it works fine on the server.

But I get the WSoD when I login unless I disable extensions in my config file.

Any ideas of what to try to fix it?

UPDATE: My local version of PHP was 5.4 but the server was 5.2. I changed it locally to match and it's working perfectly.

  • Did you try to set debug to 1 and all that? ellislab.com/expressionengine/user-guide/troubleshooting/… – Jérôme Coupé Jul 18 '13 at 8:04
  • I'm using v 1.6, I found it in the config file and have $conf['debug'] = "1"; set – MikeeBee Jul 18 '13 at 8:16
  • Can you provide a list of installed extensions? In the past I have seen this problem when there is a large image that the system is trying to create a thumbnail for. From memory I think this was down to Image Sizer plugin or a File upload plugin. This happened even if you weren't viewing the image as the system was trying to read/generate thumbnails and running out of memory. – foamcow Jul 18 '13 at 8:17
2

As per my comment above, check to see if you have a file upload add on installed (I can't recall the name of it now).

In the past I have seen this behaviour when a large image is present in an upload directory. The add-on tries to read/generate a thumbnail and runs out of memory. This happened even if you weren't directly viewing the file or an entry that contained it.

  • I do have file installed Here are my extensions: Akismet Check (v.1.1) Google Analytics Panel (v.1.1.5) jQuery for the Control Panel (v.1.1.2) Edit Remember (v.1.1.0) Documentation Edit Tab AJAX (v.1.2.2) Category Checkboxes (v.1.1) FieldFrame (v.1.4.5) File (v.2.1.2) Textile Editor Helper (TEH) (v.1.2.0) LG Add Sitename (v.1.0.1) LG .htaccess Generator (v.1.0.0) – MikeeBee Jul 18 '13 at 8:22
  • Is it Ngen File Field (I think that's the one that used to hiccup)? Check any image upload directories for large files. If you find any then try resizing and replacing them. You may also want to try removing File first to see if that makes a difference. – foamcow Jul 18 '13 at 8:33
  • Ah, how do I remove that specific fieldtype to test? (The 'file' extension is different to the Ngen file field) – MikeeBee Jul 18 '13 at 8:47
  • I may have just run into the issue where a large image file added to a entry causes the 'white screen'. I am also using the 'ImageSizer', so I'm not sure if that's a factor. – Adam Christianson Aug 28 '13 at 6:40
2

FIXED!

My local version of PHP was 5.4 but the server was 5.2. I changed it locally to match and it's working perfectly.

  • 1
    It's ok to answer your own question, in fact it's encouraged to come back and post the solution so that it may help others. You can also select this as the correct answer by using the checkbox on the left. – Adrian Macneil Aug 17 '13 at 17:11
0

Have you tried increasing the php memory limit? Both times I've hit the WSOD issue of late I've solved it by increasing memory. 32Mb just doesn't cut it especially if you're using Assets or something similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.