1

I have a three sites that are joined with MSM in EE 1.7.1. Currently, I am working to put in a better contact form for the three sites. On the two sub sites, www.watermarkcc.com/events/contact and www.sunnybrookcc.com/events/contact, the form works fine. I can modify it freely and it submits the inputs correctly. On the third site, www.stonewatercc.com/events/contact_testing, which is the main site, I get these PHP errors when I submit the form

Notice: Trying to get property of non-object in /home/stone/public_html/admin/core/core.functions.php on line 2659

Notice: Trying to get property of non-object in /home/stone/public_html/admin/core/core.functions.php on line 2659

Notice: Trying to get property of non-object in /home/stone/public_html/admin/core/core.functions.php on line 2659

Notice: Trying to get property of non-object in /home/stone/public_html/admin/core/core.functions.php on line 2659

Warning: Cannot modify header information - headers already sent by (output started at /home/stone/public_html/admin/core/core.functions.php:2659) in /home/stone/public_html/admin/core/core.functions.php on line 325

Before, I was also getting that the second parameter in the array_merge wasn't an array, and I added "(array)" to both parameters to get rid of that warning, but that leaves me with the warnings above.

Line 2659 in the file is:

$vars = array_merge((array)$vars, (array)$TMPL->embed_vars);

Line 325 in the file is:

switch($PREFS->ini('redirect_method'))
{
    case 'refresh' : header("Refresh: 0;url=$location");
    break;
    default        : header("Location: $location"); //line 325
    break;
}

Anyone have any suggestions? I am using the exact same code for all three forms so I am very confused why one isn't working.

Here's the opening tag of the form:

{exp:freeform:form form_name="sunnybrook_contact" notify="info@sunnybrookcc.com" template="custom_contact_sb" required="name|email"  return="events"}
  • I should also mention that when you submit the form, it is processed and the information is emailed to the recipient. No matter what the "return" value is in the opening tag, though, it redirects to the main page and gives the php errors. – lucky.hooligan Jul 22 '13 at 19:08
  • Not sure if this is relevant, but when I try to log out on the front end, it logs me out of EE but says that I am still logged in on the front end – lucky.hooligan Jul 22 '13 at 19:30
  • What version of FreeForm? – Jim Wyse Jul 22 '13 at 19:35
1

Apparently, this was only a problem on one browser on my computer. In that browser, it decided that I was logged into the site as the super admin and it was having trouble letting me do anything more advanced that simply looking at the sites.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.