1

Love this accessory by Brandon Kelly / P&T:

http://devot-ee.com/add-ons/module-nav

Works like a charm. Only now, I'm getting this error in the developer log:

Deprecated function generate_json() called in system/expressionengine/third_party/module_nav/acc.module_nav.php on line 82. 
Deprecated since 2.6. Use the native JSON extension (json_encode()) instead.

Appears to still be working but the forum at devot-ee is closed. Anybody know if this is still supported by the developer? Or what to do to upgrade it? Tried swapping out the function but it failed.

2

Try by replacing these $this->EE->javascript->generate_json($lang, TRUE) and $this->EE->javascript->generate_json($modules, TRUE) with json_encode($lang) and json_encode($modules)

I hope, it would work for you.

2

Appears to still be working but the forum at devot-ee is closed

P&T staff are regularly on stack exchange so I'm sure they will stop by.

I'm getting this error in the developer log

Unless you're actually an add-on developer, you should just disable the developer log warnings (I wish they were disabled by default). They are just that, only warnings, and they are really only useful to add-on developers who are in a position to fix the add-ons in question. They won't affect the stability or function of your website at all.

Deprecated function generate_json() called in system/expressionengine/third_party/module_nav/acc.module_nav.php on line 82. 
Deprecated since 2.6. Use the native JSON extension (json_encode()) instead.

This is actually really easy to fix, and since the module is open source and on github I went ahead and fixed it and made a pull request. So if you want you can try my updated version.

3
  • I'm not an add-on developer, but in terms of reporting why some problems may be happening, or why we can't achieve a certain piece of functionality with a given plugin, it's useful to have that indication of where to start troubleshooting/running down the errors. – user800 Aug 25 '13 at 21:43
  • True (and PHP errors etc are a good indicator of this). But the developer log as far as I'm aware is only used for deprecation warnings, which should have no effect at all on the functioning of your site (at least not until the next version of EE is released and the deprecated features are removed). – Adrian Macneil Aug 26 '13 at 16:53
  • Much obliged, @AdrianMacneil! Thanks for taking care of that. – Sprocket House Sep 24 '13 at 23:39
0

You could always also head over to the main Pixel and Tonic web site to ask questions about this module. I know that they recently switched all purchase and distribution from their site to devot-ee, but they do offer support, including an email address you can use to contact them directly.

Looking on their site, though, it seems that this is not listed among their offerings. You may want to ask them directly (though they do regularly engage here, so maybe one of them will pop in and give information about long-term plans / development for that module.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.