2

When trying to access a member profile page using the trigger url (e.g. mysite.com/profile) I get the following error:

The member profile you requested is currently not available

I've checked all the things I can think of. I have seen it once before on a site but given that the normal EE sites I build have very limited membership features (i.e. just the site admins) and I normally turn off member profiles/obfuscate the url I'm at a loss to work out why this is happening.

Has anyone encountered this problem before and found a fix?

7

If I recall correctly, the trigger itself is not enough - you need to append your action to the last segment

At least, thats what I figured to be the problem when I had this. I had to go to /profiles/login/ and /profiles/profile/ etc and then this worked fine.

Although this could be a bug - but is the way that I've done it.

| improve this answer | |
  • That looks like it might be it! I can't accept this answer for another 8 minutes though! – foamcow Nov 20 '12 at 21:01
3

You do need that last segment to trigger a specific profile and template.

| improve this answer | |
  • So my original question stands. Adding the extra segment makes it work. – foamcow Nov 20 '12 at 23:39
  • I wonder if it's not working without that additional segment because I am removing index.php via htaccess. – foamcow Nov 21 '12 at 18:48
  • I don't think removing index.php via .htaccess should have a negative effect in this context. I do it all the time. – Carlo Laitano Nov 24 '12 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.