4

An ExpressionEngine install has begun to throw a "no access to the directory specified for this field" error when my client and I try to save updated entries.

The error relates to three optional image fieldtypes. If no image is selected for any of the three fields using File Manager I get the error. If I select an image for each field the error does not occur.

Our EE install is up to date: 2.5.3 and I've already checked that permissions on the upload directories are correct.

The Ellislabs support forums have a couple of instances of the same error (example here) but no solution.

Any help greatly appreciated.

Update

I have just reproduced the error as a Super Admin and have a PHP error displayed on the Edit Entry screen:

A PHP Error was encountered
Severity: Notice
Message: Undefined index: filename
Filename: libraries/File_field.php
Line Number: 77
  • 2
    The fields aren't set to be 'required' are they? – Tyssen Dec 6 '12 at 12:48
  • Hello Tyssen. Thanks for the suggestion but no, the fields are not set to "required". I double checked just in case too. – Martin Jewiss Dec 7 '12 at 19:03
4

Make sure the member group you are testing is selected on the File Upload Preferences page under the Restrict file uploading to select member groups section.

Control Panel Location: Content ‣ Files ‣ File Upload Preferences

EE Docs: http://ellislab.com/expressionengine/user-guide/cp/content/files/file_upload_preferences.html#restrict-file-uploading-to-select-member-groups

  • Hi MediaGirl. Yes the member group does have the correct File Upload Permissions. I can reproduce the error as a Super Admin also. – Martin Jewiss Dec 7 '12 at 19:07
  • Any chance you have a comma in your field name? Have you tried switching from the File field to the SafeCracker File field? (ellislab.com/forums/viewthread/224834) – Anna_MediaGirl Dec 7 '12 at 19:44
  • 1
    There are no commas in the field names but there are hyphen minus symbols: 'Main Image - Left', 'Main Image - Centre', and 'Main Image - Right'. I'll try your Safecracker suggestion, thanks. – Martin Jewiss Dec 7 '12 at 20:07
  • Martin, let me know if Safecracker File throws the same error... – Anna_MediaGirl Dec 8 '12 at 15:52
  • 1
    MediaGirl, I looked into Safecracker this weekend and without dismissing your suggestion out of hand, it's not going to be an appropriate solution for my client. EE 2.5.4 and 2.5.5 were released this week, I'll upgrade asap and post back if the upgrade has fixed the problem. – Martin Jewiss Dec 23 '12 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.