1

There is a probably a very simple fix to this issue, however, I can't wrap my head around it. So I have a playa field (embedded) within a matrix field like so:

{call_out_section}
      {embed="projects/related_projects" row_count="{row_count}" xpos="{xpos}" ypos="{ypos}"} 
{/call_out_section}

embed:

  {exp:playa:children field="select_project" status="not closed"}
<a href="#" class="call_{embed:row_count}">{title} {embed:xpos}, {embed:ypos} </a><br />
{/exp:playa:children}

The result of this is:

Window Boxes 100, 100 

Dining Room Table 100, 100 

Window Boxes 200, 200 

Dining Room Table 200, 200 

I've tried adding a limit="1" on {call_out_section} and on the playa:children. The former will only return a single title and the latter returns a single pair of x/y coordinates. Any thoughts here?

7
  • I understood what is happening. Now, help me: what is the expected result?
    – Sobral
    Aug 9 '13 at 0:50
  • The expected result is 1 of each entry (not 2): 'Window Boxes 100, 100 Dining Room Table 100, 100'
    – Jon Nixon
    Aug 9 '13 at 1:12
  • Is "project" the value of a prefix parameter on the playa tag?
    – Sobral
    Aug 9 '13 at 1:19
  • Yeah, it was. I removed it for these purposes. It didn't make a difference in what I'm attempting to do..
    – Jon Nixon
    Aug 9 '13 at 1:32
  • call_out_section has 2 rows, right? 100 and 100 on the first one and 200 and 200 on the second.
    – Sobral
    Aug 9 '13 at 1:58
2

The result tells me that this entry has 2 children (Window Boxes and Dining Room) and that its field call_out_section has 2 rows (100 and 200). So, everything is right. 2 × 2 = 4!

But, as you said on chat, selected_project is also a column of call_out_section. So, you can use the Field tags of Playa, instead of exp:playa:children, that is another module with another parse, etc, etc...

So, try this:

{call_out_section}
  {select_project status="not closed" var_prefix="project"}<a href="#" class="call_{row_count}">{project:title} {xpos}, {ypos}</a><br />{/select_project}
{/call_out_section}

The strange part is that the parameter var_prefix isn't currently on docs of Field Tags.

1
  • This solved the problem for me as well. Oddly, using exp:playa:children returned incorrect results, but {field_name}...{/field_name} as noted above worked fine.
    – 4midori
    Oct 21 '13 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.