2

I'm having issues with implementing the auto opt-in mailinglist feature with Solospace's Freeform 4.

I have set up the mailing list called "jrp-mailinglist" and a landing page with the freeform on it with basic content "first name, last name, email & categories". I do not wish to have a checkbox to confirm sign-up. Eg. If they are filling out this form then have confirmed that they wish to sign up.

The freeform syntax I have used is:

{exp:freeform:form 
mailinglist_opt_in="no"
mailinglist="jrp-mailinglist" 
form_id="3"
required="first_name|last_name|email|sign_up_categories"
return="sign-up/thanks"
}

But am unsure how to use the mailinglist field type.

I have gone through the Freeform4 docs (http://www.solspace.com/docs/freeform/default_fieldtypes/#mailinglist) but am unable to see where it clearly outlines how to implement the auto opt-in for my selected mailinglist.

Any help or advise would be greatly appreciated.

Thanks, Dan

2

You have to tell Freeform which mailing list you want the user to subscribe to in this way:

<input type="checkbox" name="mailinglist[1]" value="y" checked="checked"/>

Note: mailinglist[1] should be replaced with your short field name and the number of the mailing list you want the user to opt into.

You can also have Freeform spit it out automatically by using this tag:

{freeform:field:mailinglist}

I hope that helps!

| improve this answer | |
1

Have you tried removing this parameter? mailinglist_opt_in="no" Make sure you have the "Opt in by default" checked.

If you don't want the field to display. You will probably have to code that into a hidden field.

Hope this helps.

Jim

| improve this answer | |
1

In Freeform 4, the mailing list options are in the mailinglist field creation area: http://cl.ly/image/2o3o153c3S0q

Freeform 4 differs from Freeform 3 in that the Mailinglist options are all custom field based and no longer parameter based.

| improve this answer | |
  • Thanks for your answer. Even after checking those options, the user does not get added to the selected mailing list by default - I have to go into the form entries & manually check the mailing list checkbox (not really automated) – Dan Aug 15 '13 at 7:49
  • That sounds like a bug. I'll submit it to our tracker so we can check it out. – user550 Aug 27 '13 at 2:36
  • 1
    Greg, I too am having this problem and I think it's around the use of the mailing list custom fieldtype. I'm not sure the docs explain its use properly, do you have an example form layout using one please? – Adam Wiggall Aug 27 '13 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.