0

I've just upgraded a site to EE2.6 with P&T Fieldpack 2.1

all of my safecracker dropdowns are now giving {option_name} instead of my proper Options. My dropdown template code is using the following

{options:myfieldname} {option_name} {/options:myfieldname}

This code output correctly with EE2.5.5 and P&T Dropdown 1

Can anyone help out with the correct Dropdown syntax or a working solution?

5

The {options:field_name} tag pair is actually a Safecracker tag, which only works with Field Pack 1.x out of the box. You can add Field Pack 2.x support by opening up system/expressionengine/config/config.php and adding these lines:

$config['safecracker_option_fields'][] = 'fieldpack_checkboxes';
$config['safecracker_option_fields'][] = 'fieldpack_radio_buttons';
$config['safecracker_option_fields'][] = 'fieldpack_dropdown';
$config['safecracker_option_fields'][] = 'fieldpack_multiselect';
$config['safecracker_option_fields'][] = 'fieldpack_pill';
| improve this answer | |
  • What effect would this have if I upgrade to 2.7.2? – Sarcastron Nov 6 '13 at 18:46
  • Same; this applies to EE 2.6 and later. – Brandon Kelly Nov 11 '13 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.