3

I am building my first Expresso Store and having some trouble making fields required. Here is what my checkout form looks like. Note all the fields that that I have marked as required. When I submit the form, it validates the order_email and displays the error message inline. When I fill out the email field and hit submit, none of the other fields are validated.

I'm on EE 2.6.1 and Store 1.6.4.

Thanks in advance for any help.

  • 1
    I seem to remember having an issue like this before. Can't quite remember what the problem ended up being, but if I remember correctly, it had something to do with not having tags in the template to output errors for all of the fields being validated. – Jeremy Gimbel Aug 14 '13 at 18:36
  • 1
    If you remove error_handling="inline" do you see any errors? – Adrian Macneil Aug 14 '13 at 18:58
  • I have the same experience. I see the error message about Email being required, but when I fill out the email field and submit, no other error messages are shown. – Trevor Davis Aug 14 '13 at 19:53
  • Do you have a link to the development site we can take a look at? – Adrian Macneil Aug 15 '13 at 17:31
  • Just sent an email to support@exp-resso.com with the URL. Thanks! – Trevor Davis Aug 15 '13 at 18:30
1

Generally if there are no errors displaying, but the form is submitting, it's because there are some other validation errors which you don't have inline errors in your template for.

Try removing error_handling="inline" from your tag, then resubmit the form and see which errors display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.