1

I hate to complain about a freebie add-on - EE Debug Toolbar from mitra62 - but unfortunately installing EE Debug Toolbar has just caused me major problems.

The good news is that my site is still up.

The bad news is that I can't login as a superadmin at all.

The story is:

My EE site uses the latest version of EE and of MSM.

I just downloaded version 1.0 (RC1) of EE Debug Toolbar from Devot-ee.com

I followed the instructions on GitHub (just before it's current DDOS attack) including turning on the EE debugging reporting. I uploaded all the files that came with the download in the usual sections.

I went to Extensions and activated EE Debug. There was a list of things to activate, I believe I started with the first one on the list because it seemed the most general. I'm sorry but this is all I can recall about this step.

I got this error message:

Fatal error: Class 'XMLWriter' not found in /var/www/html/system/expressionengine/third_party/ee_debug_toolbar/libraries/xml_writer.php on line 35

My superadmin access to the site stalled there.

I went back to GitHub to look for help.

GitHub is experiencing a DD0S attack and is down.

I tried to log onto my super admin account from another browser and got the error message.

I got impatient and deleted all the EE Debug addons from the system and themes folder.

Now I just get a white screen when I try to log on to my superadmin account.

How do I get back in as superadmin now?

Thanks for any help you can provide.

Jeanne

0

It seems like there may be files missing from your upload. I would try reuploading the add-on to make sure all files were included. The error seems to be pointing to a missing file within the add-on's package directory.

In the meantime to get you back into the control panel, you can go into your database, find the exp_extensions table, find the EE Debug Toolbar record and set the value of the enabled field to n. This will disable the extension and should prevent it from interrupting your access to the control panel.

| improve this answer | |
  • Thanks! Changing the exp_extensions table solved the superadmin login problem. – Jeanne Pickering Aug 15 '13 at 19:32
  • The original problem occurred because EE Debug Toolbar has, <a href="github.com/accent-interactive/…> which is a class that extends XMLWriter which comes with PHP5 by default. Unfortunately, the configure command for PHP5 was written with "disable-xmlwriter" which is why the error message said "Class XMLWriter not found." – Jeanne Pickering Aug 15 '13 at 19:38
  • 1
    A followup: the site runs with Apache/2.2., Linux 5.5 (CentOS) and PHP/5.3.27 on a Rackspace cloud. By creating another .ini in the /etc/php.d/ directory, I was able to enable both XMLWriter and XMLReader. For anyone who is just wading into these waters, as I am, the procedure is to: 1)create a file named XMLWriter.ini 2) put this code into the file: extension=xmlwriter.so 3) save and then restart Apache. Repeat for XMLReader, with appropriate file name changes. – Jeanne Pickering Aug 19 '13 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.