1

I have set this hidden variable in my config/config.php file

// Allows changing of the Users Session Length to any number in seconds. For instance, if users should be logged out after 10 minutes of inactivity, the value would be: 600
// 30 minutes(60 seconds * 30 )
$config['user_session_ttl'] = 1800; 

However, it is not working. I tried leaving a page inactive and checking it after an hour many times. But I still don't get logged out.

Any idea why this is the case?

P.S. I am using Safecracker and Safecracker Registration for my Member system. I am using EE 2.5.5 with no immediate plans to upgrade.

UPDATE:

I found out that user_session_ttl affects my admin session(logged in via localhost/system) while the session logged in via Safecracker was not affected.

I also found another hidden variable, cp_session_ttl. Is this relevant?

9
  • Try by having like this $config['user_session_ttl'] = "1800"; – Bhashkar Yadav Aug 16 '13 at 10:18
  • I tried enclosing it in double quotes and changing the value to just 1 to test if it really is logging out. It didn't work. – developarvin Aug 17 '13 at 8:10
  • Added an observation. – developarvin Aug 19 '13 at 2:55
  • I would suggest you to see this extension also johndwells.com/software/stay-up-forever In this, you can set the user session time from extension settings. – Bhashkar Yadav Aug 19 '13 at 7:29
  • @BhashkarYadav I tried following your link. But I only saw an error page. – developarvin Aug 19 '13 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.